ArcView®
3D Analyst

3D Surface Creation, Visualization, and Analysis
CHAPTER 1

Introduction to the ArcView 3D Analyst

The ArcView® 3D Analyst™ adds many powerful capabilities to your desktop GIS. Through tutorials and step-by-step examples, this book will show you how to analyze and visualize surface data, not only through the interface tools it provides, but through its extensions to the Avenue™ scripting language, which allow you to create powerful custom applications.

The 3D Analyst enables you to perform a wide range of activities:

- Create realistic surface models from multiple input sources.
- Determine height at any location on a surface.
- Find what is visible from an observation point.
- Calculate the volumetric difference between two surfaces.
- Work with 3D vector features to make realistic models of the 3D world.
- Visualize your data in 3D.
What you can do with the 3D Analyst

The 3D Analyst provides two types of surface models, grids and TINs, for modeling continuous data, like terrain elevation or temperature gradient. 3D vector features, where X, Y, and Z coordinates are stored for every vertex, let you capture and represent geographic features precisely. Analytic operators and 3D visualization tools tie these and the rest of ArcView GIS software’s capabilities together into one integrated, easy-to-use system.

Surfaces can be created from a wide variety of data sources. You can make grids by importing USGS DEMs, DTED files, raw ASCII files, or one of many image formats. You can also create grids from point data using interpolators such as IDW, spline, or kriging. TINs can be created by triangulating features represented by points, lines, and polygons or from grids. You can even modify your TINs by adding new data to them.

With these surfaces the 3D Analyst can create spot heights, profiles, contours, viewsheds, steepest paths, and more. This new information, produced from surface analysis functions, can be used on its own or be fed back into the GIS to be modeled with other spatial data and operators.

Lines of steepest path overlaid on a hillshaded surface reveal flow patterns.

In addition to creating and analyzing surfaces the 3D Analyst is a powerful visualization tool for creating 3D perspective displays. You can pack more information into a perspective display, and a perspective is easier for people to interpret.

The 3D Analyst is a valuable tool for creating 3D models of the land and for creating thematic data as can be used for choropleth maps.

Many of the tools used for displaying data in the 3D View, but also interactively ti
of surface models, grids and TINs, for modeling
on or temperature gradient. 3D vector features, where
or every vertex, let you capture and represent
ytic operators and 3D visualization tools tie these and
capabilities together into one integrated, easy-to-use

variety of data sources. You can make grids by
raw ASCII files, or one of many image formats. You
using interpolators such as IDW, spline, or kriging,
g features represented by points, lines, and polygons
your TINs by adding new data to them.

can create spot heights, profiles, contours, viewsheds,
formation, produced from surface analysis
be fed back into the GIS to be modeled with other

radial surface reveal flow patterns.

surfaces the 3D Analyst is a powerful visualization
ays. You can pack more information into a
is easier for people to interpret.

On the left is the footprint of a construction project. It shows how much area the project will take up,
but little else. On the right is a 3D view of the site. It shows how it will actually look in relationship to
what’s already there.

The 3D Analyst is a valuable tool even when the only data available is 2D. Attributes of
themetic data can be used for height, facilitating the creation of 3D block diagrams or
choropleth maps.

State counties extruded by population. Counties are differentiated by color and population is
indicated by height.

Many of the tools used for display and query in the view document also work in 3D.
Themes are symbolized in the same fashion as in views. Tools for identifying and
selecting features also work the same. So you get up to speed quickly, without having to
learn a lot of new concepts.

When displaying data in the 3D environment, not only can you pan and zoom like in a
View, but also interactively tilt and rotate the data to change the viewing perspective.
Learning the 3D Analyst

The more you know about ArcView, the better prepared you'll be to use the 3D Analyst. We've assumed that you're already familiar with ArcView GIS and that you have at least worked through the ArcView Quick Start Guide and spent some time exploring the software. (If you haven't done so already, you should read *Using ArcView GIS* to familiarize yourself with the ArcView GIS user interface and "out of the box" capabilities.)

What to read next

Chapter 2 of this book is a tutorial. In it, you can learn how to visualize data in 3D, how to create surface models, and how to perform a number of analytic tasks on surfaces. After reading Chapter 2, you'll be able to perform basic tasks with the software and be ready to master the advanced topics presented in the rest of the book.
How to get online help

To find out what a button, tool, or menu choice does
- Move the cursor over it but do not select it. A short description will appear in the status bar.

To get help about a button, tool, or menu choice
1. Click the Help button.
2. Click the button, tool, or menu choice you want to get help about.

To get help about a dialog box
- Press the F1 key on your keyboard when the dialog is displayed.

To use the ArcView GIS help
1. From the Help menu, choose Help Topics.
2. Click the Contents tab or the index tab.

To search the ArcView GIS help for a particular word
1. From the Help menu, choose Help Topics.
2. Click the Find tab.

Getting technical support from ESRI

Please see the product registration and support card that came with ArcView GIS, or look at the "Obtaining technical support" section of the ArcView GIS online help.

Visit ESRI on the Web

CHAPTER 2

Quick start tutorial

NOTE: NETWORK FILES ARE LOCATED IN
THE V:\\ESRI AV GIS30\AVUTOR\3D

This chapter presents five step-by-step exercises, beginning with simple
display and query tasks in 3D and progressing to more complex analysis
and visualization. These present just the basics. You'll be able to learn more
about these topics in the other chapters of this book and in the ArcView GIS
online help.

Before you start this tutorial, you should already have gone through the
ArcView Quick Start and should already know basic ArcView GIS
terminology and interface concepts. You should also be familiar with the
analysis capabilities of ArcView GIS.

• Exercise 1: Viewing in perspective
• Exercise 2: Creating and populating a 3D scene
• Exercise 3: Creating 3D shapes
  • Exercise 4: Surface analysis
  • Exercise 5: Advanced visualization
Exercise 1: Viewing in perspective

3D scenes are used like ArcView views to display and query geographic data. In this exercise, you’ll view features from different angles and learn how to identify and select them.

To open the project for this exercise
1. Choose Open Project from the File menu.
2. In the Open Project dialog, navigate to the Avtutor\3d directory.
3. Double-click on tutor1.apr.

When the project has opened, you’ll see two windows that belong to a 3D scene. One window is a 3D scene Table of Contents named 3D Scene1. Like a view’s Table of Contents, it lists the legends for the themes in the scene. The second window is a 3D scene viewer named 3D Scene1-Viewer1, which is used to display the themes in a 3D scene. You can open up as many viewers as you need and move them outside the ArcView application window.

![Image of 3D scene viewer]

The 3D scene in this exercise has two themes: terrain and buildings.

To navigate a scene
1. With the viewer Navigate tool selected, and the cursor in the display area, press the left mouse button and move the mouse in any direction to rotate the data. Depending on how long it takes to redraw a theme when you’re navigating, the software may switch to a simpler version of the theme, like a 3D bounding box, to improve performance while interacting.

To identify features
1. Make both the Bldg.shp a active theme for the Identify tool.
2. Choose the Identify tool.
3. Click over one of the building objects providing information about the selected object.
4. Click on other buildings to see the corresponding terrain model.
5. Click on the terrain model.

You can identify while in navigation by holding down the SHIFT key and using the arrows to move the cursor around the map.

To select features
1. Choose the Select Feature tool.
2. Make sure the Bldg.shp is selected.
3. Click over one of the buildings.
4. Click on another building.
5. While holding down the SHIFT key, click on the terrain model.
6. Press the Open Theme Tool to see the selection of the corresponding buildings in the terrain model.
7. Using the table Select tool, select the corresponding buildings in the terrain model.
ive

t to display and query geographic data. In this
different angles and learn how to identify and select

cise

File menu.

igate to the Avtutor3d directory.

see two windows that belong to a 3D scene. One
ents named 3D Scene1. Like a view’s Table of
themes in the scene. The second window is a 3D
ver1, which is used to display the themes in a 3D
ers as you need and move them outside the

tnet and buildings.

selected, and the cursor in the display area, press
c mouse in any direction to rotate the data.
redraw a theme when you’re navigating, the
version of the theme, like a 3D bounding box, to

2. Press the right mouse button and move the mouse up and down to zoom in and out.
3. Press both left and right mouse buttons (or the middle button on a 3-button mouse) and move the mouse to pan.
4. Press the Zoom to Full Extent button in the viewer to reset the perspective.
5. Press the Rotate button to have the scene spin around automatically. Press the ESC key on your keyboard, or the Stop button on the bottom right of the ArcView application window, to halt the rotation.

To Identify features
1. Make both the Bldg.shp and Dtm_tin themes active. You must have at least one active theme for the Identify tool to be enabled. It will only report on features contained in active themes.
2. Choose the Identify tool on the viewer.
3. Click over one of the buildings with the cursor. The Identify window will come up providing information about the building you pointed to.
4. Click on other buildings to see their records.
5. Click on the terrain model to get information about it.

You can identify while in navigate mode without having to switch to the Identify tool by holding down the SHIFT key on the keyboard then clicking on one of the buildings or the terrain model.

To select features
1. Choose the Select Features tool.
2. Make sure the Bldg.shp theme is active.
3. Click over one of the buildings with the cursor. It will become highlighted.
4. Click over another building; the selection will switch.
5. While holding down the SHIFT key, click on a building. This adds to the selection.
6. Press the Open Theme Table button. Scroll through the table to see that the records of the selected buildings are also highlighted.
7. Using the table Select tool, select some of the records in the table. The corresponding buildings will be highlighted in the viewer.
To define 3D scene properties
1. Choose Properties from the 3D Scene menu.
2. Press the Background color Select...button, choose a dark blue, and press OK on the Color Picker.
3. Change the Vertical exaggeration factor to 1.5, then press OK.

Exercise 2: Creating and populating a 3D scene

In this exercise you'll learn how to create the 3D scene used in Exercise 1. To do this you'll open a new 3D scene, add themes to it, create a terrain model, and define properties for buildings to display them in 3D.

To open a new 3D scene document
1. Make the project window active, then choose New Project from the File menu. Choose 'No' if you're asked to save the project from Exercise 1.
2. From the File menu choose Extensions... then select the 3D Analyst and press OK.
3. Make the 3D Scenes icon at the left of the project window active. You may need to scroll down the list of icons before you can see it.
4. Click New to open a new 3D scene.

To add data to the 3D scene
1. Press the Add Theme button
2. Navigate to the avtoru3
3. Select and add the Bklynz.shp
4. Click the Zoom to Full Extent button
5. Turn on all three themes

The Bklynz.shp and Masspatz themes have z values. One has mass p breaklines, which are linear features. The Perim.shp theme is the boundary of the Perim.shp theme displays flat.

You'll use these three themes

To create a TIN theme of the
1. In addition to the Perim.shp Masspatz and Bklynz
2. Select Create TIN Layer
3. In the Create new TIN dialog box Themes scroll list. See how the TIN theme
4. Highlight the other two themes and their default settings.
5. Press OK then provide a description
6. Choose Delete Themes from the TIN theme dropdown and Bklynz.shp theme when asked, choose Yes
7. Turn on the TIN theme.

The Height source dropdown on the Bklynz.shp and Masspatz.shp taken from the surface defined in the TIN theme.

To see the buildings displayed in the TIN theme to get the building base that base by a value equal to th
To add data to the 3D scene
1. Press the Add Theme button.
2. Navigate to the avnutor3dsite1 directory.
3. Set the Data Source Types to Feature Data Source.
4. Select and add brklinz.shp, massptsz.shp, and perim.shp as themes.
5. Click the Zoom to Full Extent button on the viewer.
6. Turn on all three themes for display.

The Brklinz.shp and Massptsz.shp themes contain 3D features and are displayed using their z values. One has mass points with measured spot heights. The other contains breaklines, which are linear features on the terrain such as roadsides and ridgelines. The Perim.shp theme is the boundary for the study area. Because it's a 2D feature, the Perim.shp theme displays flat, under the other two themes.

You'll use these three themes to create a TIN-based terrain model.

To create a TIN theme of terrain
1. In addition to the Perim.shp theme which should already be active, make the Massptsz.shp and Brklinz.shp themes active.
2. Choose Create TIN From Features in the Surface menu.
3. In the Create new TIN dialog, highlight the Perim.shp entry in the Active Feature Themes scroll list. See how the default settings are listed for the theme in the fields to the right.
4. Highlight the other two themes listed in the Active Feature Themes scroll list to see their default settings.
5. Press OK then provide a directory and name the output TIN.
6. Choose Delete Themes from the Edit menu to remove the Perim.shp, Massptsz.shp, and Brklinz.shp themes from the Table of Contents; they aren't needed anymore. When asked, choose Yes to All to delete all three themes.
7. Turn on the TIN theme.

The Height source dropdown on the Create New TIN dialog offers a Shape field for both the Brklinz.shp and Massptsz.shp but not for Perim.shp. Heights for Perim.shp will be taken from the surface defined by the mass points and breaklines.

To see the buildings displayed in 3D on top of the TIN, you have to tell the Bldg.shp theme to get the building base heights from the TIN surface and to extrude them up from that base by a value equal to their height.
To display buildings in 3D

1. Press the Add Theme button, set the Data Source Types to Feature Data Source, and navigate to the aviator/3d/diag1 directory.

2. Add bldg.shp as a theme.

3. Draw the Bldg.shp theme. These are 2D features and will display flat, below the TIN.

4. Make the Bldg.shp theme active.

5. From the Theme menu choose 3D Properties.

6. In the Assign base heights by panel select the Surface radio button.

7. In the Extrude features by value or expression panel press the Calculator button located to the right of the scrollable edit box.

8. Define the expression '(Stories) * 10' and press OK.

9. Set the Extrude by field to Adding to min z value.


To change the color of the buildings

1. Double-click on the Bldg.shp theme legend in the Table of Contents to bring up its Legend Editor.

2. Set the Legend Type to Unique Value and the Values Field to Owner.

3. Press Apply and dismiss the Legend Editor.

4. Now go ahead and use the 3D scene properties to adjust the vertical exaggeration, change the background color, or reset the sun position.

Exercise 3: Creating 3D shapes

As shown in Exercises 1 and 2, you can view 2D shapes in perspective by converting them to 3D on the fly. The 3D properties you define are temporary and must be defined again if you want to view these shapes in perspective in another project. If you'd like to distribute the shapes and have them immediately viewable in 3D without ancillary data, like a surface model, you'll need to store the shapes as 3D entities, where height is maintained as part of the feature geometry.

In this exercise you'll use both attribute information and a surface to provide heights.

To open the project for this exercise

1. Make the project window active.

2. Choose Open Project from the File menu.
set the Data Source Types to Feature Data Source, and 1 directory.

are 2D features and will display flat, below the TIN.

3D Properties.
panel select the Surface radio button.
expression panel press the Calculator button.
ible edit box.
* 10' and press OK.
arg to min z value.
alog.
ings
ne legend in the Table of Contents to bring up its
Value and the Values Field to Owner.
end Editor.
ne properties to adjust the vertical exaggeration,
reset the sun position.

an view 2D shapes in perspective by converting
ties you define are temporary and must be defined
in perspective in another project. If you’d like to
mediately viewable in 3D without ancillary data,
be the shapes as 3D entities, where height is
etry.
te information and a surface to provide heights.
ise
le menu.

3. If you’re asked to save the project from the previous exercise, choose No.
4. Navigate to the avutord3d directory and open tutor3d.apr.

You should see three themes: Wells.shp, Roads.shp, and Dtm_tin. The Roads.shp and Wells.shp themes display below Dtm_tin because they are 2D themes without height information.

To create 3D points using an attribute representing height
1. Make sure the Wells.shp theme is active.
2. Choose Convert to 3D Shapefile from the Theme menu.
3. Set the Get Z values from dropdown choice to Attribute and press OK.
4. From the dropdown list that appears, select GL_elev, the ground-level elevation of the wells.
5. In the dialog that asks what to use for an output name, specify wells1.shp and press OK. The output shapefile will be created.
6. When asked whether you’d like the shapefile added as a theme, answer Yes.
7. Delete the 2D Wells.shp theme.
8. Draw the Wells1.shp theme.

You may have trouble seeing the points because they’re the same height as the surface. Feature height determines what gets drawn on top, not theme order as in views. When two features are at the same height you can’t be assured you’ll see either very well. To alleviate this, either turn off the display of Dtm_tin or raise the wells a few units above the surface with the Offset heights option that’s in the 3D Properties dialog under the Theme menu.
To create 3D lines by overlaying features on a surface model

1. Make the Roads.shp theme active.
2. Choose Convert to 3D Shapefile from the Theme menu.
3. Set the Get Z values from dropdown choice to Surface and press OK. When prompted for a surface, select Dtm.tin.
4. Name the output roadsz1.shp and press OK.
5. When asked whether you'd like the shapefile added as a theme, answer Yes.
6. Delete the 2D Roads.shp theme.
7. Turn on the display of the Roads1.shp theme.

This will interpolate height information for the roads from the Dtm.tin theme, converting the 2D lines features into 3D.

As with the wells, you may have trouble seeing the roads because they're at the same height as the surface and can be obscured by it. You can either turn off the display of Dtm.tin or raise the roads a few units above the surface with the Offset heights option in the 3D Properties dialog under the Theme menu.

You can also define 3D graphics with the cursor. Heights for the graphics are interpolated off the active TIN or grid theme. There are tools for lines, points, and polygon boundaries. These tools are found in the view document and enabled when a TIN or grid theme is active.

To create 3D shapes interactively

1. Make the Dtm_tin theme active.
2. Choose Copy Themes from the Edit menu.
3. Choose Close from the File menu. The 3D scene Table of Contents and its viewer will automatically be dismissed.
4. Open a new view.
5. Choose Paste from the view Edit menu.
6. Make the Dtm_tin theme active and make sure its display is on.
7. Select the Interpolate Line tool from the toolbar.
8. Bring the cursor into the view window, over the TIN, and enter a polyline by clicking the left mouse button. Single clicks add new vertices while a double click ends the line. Add several lines, horizontal and vertical.
9. Choose Select All Graphics from the Edit menu.

Exercise 4: Surface analysis

In this exercise you'll learn how to contour a surface, how to perform graph.

To open the project for this e

1. Make the project window as
2. Choose Open Project under i
3. If you're asked to save a pro
4. Navigate to the avtutor3d d

To query elevation, slope, an

1. Make sure the Dtm_tin then
2. Go to the toolbar and select
3. Bring the cursor into the view left mouse button. An Identify location in the left panel, an panel.
4. Dismiss the Identify Results
Exercise 4: Surface analysis

In this exercise you'll learn how to query point-based information from surfaces, how to contour a surface, how to perform line of sight analysis, and how to create a profile graph.

To open the project for this exercise
1. Make the project window active.
2. Choose Open Project under the File menu.
3. If you're asked to save a project from a previous exercise choose No.
4. Navigate to the avtutor3d directory and open tutor4.apr.

To query elevation, slope, and aspect from TIN themes
1. Make sure the Dtm_tin theme in the view Table of Contents is active.
2. Go to the toolbar and select the Identify tool.
3. Bring the cursor into the view window over the TIN and enter a point by clicking the left mouse button. An Identify window will pop up listing the theme name and xy location in the left panel, and the location's elevation, slope, and aspect in the right panel.
4. Dismiss the Identify Results window.
Contours are lines that connect points of the same height. They are frequently used on maps to convey information about topography.

**To create contours**

1. Choose Create Contours from the Surface menu.
2. Accept the defaults and press OK. A new theme of contours will be added to the view.
3. Turn on the Contours of Dtm_tin theme to see the resulting contour lines.

The Line of Sight tool determines what is visible between an observer and target and whether the target itself is visible.

**To perform line of sight analysis**

1. Make sure the Dtm_tin theme is active.
2. Click and hold the left mouse button over the Contour tool. This will expose the Line of Sight tool that's underneath it. Select the Line of Sight tool.
3. Set the observer height offset to 20.0, accept the default of 0.0 for the target and press OK.
4. With the cursor over the display of the Dtm_tin theme, press down the left mouse button to position the observation point and while holding down the left button move the cursor to a target position and release.
5. Do this for several lines.

A report indicating whether the target is visible is listed in the ArcView status bar at the bottom of the Application window. That portion along the line of sight that's visible is drawn in green. The invisible portion is drawn in red. If the target is not visible, the first obstruction point will be included with a blue marker.

The observer and target heights are set equal to the z value of the surface at their locations plus the offsets you specified. To bring up the dialog to change the offset settings, click the Line of Sight tool button, even if it's currently active.

6. When finished choose Select All Graphics followed by Delete Graphics from the Edit menu.

The Profile Graph tool will take selected 3D lines from either the graphics or the active theme and create a graph that shows the height measured along the lines.

---

**Exercise 5: Advanced visualiz**

In this exercise you'll learn two themes comprised of several data sets. Discover the relationships between themes. See appearance of themes while interact faster when working with larger di
points of the same height. They are frequently used on topography.

the Surface menu. OK A new theme of contours will be added to the tin theme to see the resulting contour lines.

is visible between an observer and target and

is active.

button over the Contour tool This will expose the beneath it. Select the Line of Sight tool.

0 20.0, accept the default of 0.0 for the target and y of the Dtm_tin theme, press down the left mouse button and while holding down the left button button and release.

et is visible listed in the ArcView status bar at the that portion along the line of sight that’s visible is z is drawn in red. If the target is not visible, the first ith a blue marker.

et equal to the z value of the surface at their end. To bring up the dialog to change the offset button, even if it’s currently active.

Graphics followed by Delete Graphics from the.

red 3D lines from either the graphics or the active the height measured along the lines.

To create a profile graph

1. Make sure the Dtm_tin theme is active.
2. Choose the Interpolate Line tool
3. Bring the cursor into the view window, over the TIN, and enter a polyline by clicking the left mouse button. Single clicks add new vertices, a double click ends the line.
4. Open a new Layout.
5. Choose the Profile Graph tool
6. With the cursor define a box on the layout page.
7. Accept the defaults listed in the Profile Graph Properties dialog and press OK.

The resulting graph is a grouped collection of graphics. You can move the graphics around, ungroup them, and change their properties as you would other graph features. Be aware if you resize the graph the vertical exaggeration printed under the title will become invalid.

Exercise 5: Advanced visualization

In this exercise you will learn two things. First, how to create a multilayered display comprised of several data sets. Displays of this type are useful because they help you see relationships between themes. Second, how to control rendering performance and appearance of themes while interacting in a 3D scene. This can make the navigate tool faster when working with larger data sets.
To open the first project for this exercise
1. Make the project window active.
2. Choose Open Project under the File menu.
3. If you’re asked to save a project from a previous exercise, choose No.
4. Navigate to the av tutor/3d directory and open tutor5a.apr.
5. You’ll see a 3D scene with themes representing utility lines, buildings, and an orthophoto drawn in its viewer.

To create a multilayered display
1. Make sure the Chem_grd theme is active.
2. Choose 3D Properties under the Theme menu.
3. In the ‘Assign base heights by’ panel, to the right of the Surface choice, press the file browser button ➡.
4. Navigate to the av tutor/3d/site2 directory, make sure the Data Source Types is set to Tin, and double click wtab_tin.
5. Press OK on the 3D Properties dialog and turn on the display of Chem_grd.
6. Make the Wells.shp theme active.
7. Choose 3D Properties under the Theme menu.
8. In the ‘Assign base heights by’ panel, set the Surface to Dtm_tin.
9. In the Extrusion panel, press the calculator button ➢.
10. Create the expression ‘[Wtab_elev]’ and press OK.
11. Set Extrude by to Using as absolute.
12. Press OK on the 3D Properties dialog then turn on the display of Wells.shp.

You will see the wells displayed as vertical lines between two surfaces, the terrain and the water table. The terrain is represented by a digital orthophoto draped over a terrain model. The water table surface has a grid of chemical contaminant levels draped over it. While the wells are 2D point data, they have been extruded into vertical lines through the 3D Properties dialog.

To open the second project for this exercise
1. Make the project window active.
2. Under the File menu choose G.
3. If you’re asked to save a project from a previous exercise, choose No.
4. Navigate to the av tutor/3d directory.

You’ll see a 3D scene comprised of

To control 3D theme rendering
1. Make sure the Navigate tool is active.
2. With the Globe.shp theme active.
3. Press the Advanced button on the 3D Properties dialog.
4. In the input field called ‘Use size value’ enter 0.1.
5. Press OK on the Advanced 3D Properties dialog.
6. Use the left mouse button to rotate the viewpoint, and when you stop navigating it will turn...
To open the second project for this exercise

1. Make the project window active.
2. Under the File menu choose Open Project.
3. If you’re asked to save a project from a previous exercise, choose No.
4. Navigate to the avtutor3d directory and open tutor5b.apr.

You’ll see a 3D scene comprised of a globe, with countries drawn in different colors.

To control 3D theme rendering performance

1. Make sure the Navigate tool is active and use the left mouse button to spin the globe around. It’s probably very sluggish.
2. With the Globe.shp theme active choose 3D Properties... from the Theme menu.
3. Press the Advanced button on the 3D Properties dialog.
4. In the input field called ‘Use simplified version if theme refresh exceeds:’ enter the value 0.1.
5. Press OK on the Advanced 3D Properties dialog and then OK on the regular 3D Properties dialog.
6. Use the left mouse button to rotate the globe. It will now turn into a 3D box. When you stop navigating it will turn back into its full representation.
You can control how much time is allowed for a theme to try and render itself in full detail before it switches to a simpler representation to boost navigation performance. Note that this control is theme based, so the maximum time it will take for an entire 3D scene to refresh one frame is the sum of the time allotted all themes comprising the scene.

**To control theme representation during interaction**

1. With the Globe.shp theme active choose 3D Properties... from the Theme menu.
2. Press the Advanced button on the 3D Properties dialog.
3. Turn off the Draw theme when interacting option.
4. Press OK on both dialogs.
5. Make the Ctrynd.shp theme active and choose 3D Properties from the Theme menu.
6. Press the Advanced button on the 3D Properties dialog.
7. Turn on the Draw theme when interacting option.
8. Press OK on both dialogs.
9. Use the left mouse button to rotate the globe.

Now when you navigate, the simple complex Globe.shp theme will turn opposite occurs; the Ctrynd.shp

This tutorial has exposed you to j remaining chapters in this book through better understanding, to t
allowed for a theme to try and render itself in full or representation to boost navigation performance. And so the maximum time it will take for an entire 3D m of the time allotted all themes comprising the scene.

**on during interaction**

we choose 3D Properties... from the Theme menu.

the 3D Properties dialog.

interacting option.

active and choose 3D Properties from the Theme.

3D Properties dialog.

interacting option.

the globe.

Now when you navigate, the simpler Ctrybud.shp theme will draw but the more complex Globe.shp theme will turn off altogether. When you stop navigating, the opposite occurs; the Ctrybud.shp will turn off and Globe.shp turns on.

This tutorial has exposed you to just some of the capabilities of the 3D Analyst. The remaining chapters in this book go into greater detail on each topic and will enable you, through better understanding, to use the product more effectively.