Chapter 2. Working with ArcMap

Mastering the Concepts
Objectives

» Learning how to manage and use ArcMap windows and menus
Adding feature datasets and tables to a map document
Drawing features using different symbols
Getting informationlabout features using Find and Identify

Understanding and using map scale when diéplaying features

Y V¥V v Vv Y

Labeling features as simple text, dynamic labels, and annotation

Concepts

Map documents

- ArcMap works with map documents, just as
Microsoft Word works with Word documents. A South Dakota
map document is a collection of different spatial ¢ Maribeth Price
data layers and tables, along with instructions for
how the layers will be displayed. Just as texton a

: : . RS BN i
page has properties such as its font, size, and t%@& R 8 S
style, map features have properties that control . eI et

the symbol, color, and style with which they are

" drawn. Tables have properties that specify which
fields are shown, how many decimal places are
included, and s& on. The map document keeps
track of all these layers and their properties, so
that when it is opened again, the map appears
exactly as it was when it was last saved. Even the
size of the windows and the locations of the
toolbars are stored when saving the document.

Map documents organize the data using data
frames. A data frame is a window in the
document that contains groups of related layers
that are drawn together. Maps can contain Fig. 2.1. A map document with two
multiple data frames. For example, a document data frames, one of South Dakota and
could contain a data frame with a detailed map of one of the United States

South Dakota, and another frame showing the

location of South Dakota in the United States

(Fig. 2.1). Both frames are included when printing the map.
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Unlike the pictures placed in this book document, which are completely saved within the
document itself, a map document does not store the features and tables of the data sets within the
map document. Instead, the map stores the name and disk location of the spatial data—its
source. Changes to the map document do not affect the source data except for specific actions
such as adding fields or editing shapes. Changing display symbols, sorting tables—these actions
do not affect the source data at all.

It is important to realize that, because the source data are stored outside the map document,
changes to source data made in one map document affect all map documents using the same data
set. For example, imagine that Jim creates a map of the United States, saves it, and goes to lunch.
During lunch, Peggy opens her map, which uses the same states shapefile, and begins to practice
editing. She deletes the states of California and Texas, and then accidentally saves her changes.
When Jim comes back from lunch and opens his map again to continue working, he finds that
California and Texas are missing.

Most organizations take steps to protect their spatial data sets from being accidentally changed,
precisely because the mistake of one can affect the work of many. Often the source files are
write-protected so that only specific users are authorized to make changes. Others like Peggy,
who want to practice editing the data, must make a copy of the original to work with. Before
making any permanent changes to source files, stop and carefully consider who owns and uses the
data, and who else might be affected by changes. If in doubt, create a copy to work on.

The storage of the map document and the source data in separate locations also has implications
for sharing map documents. Giving a colleague a copy of a map document, by e-mail for
example, only works if the recipient has access to exactly the same data in the same disk location
as the original user. Map documents keep track of the source files by storing the name and
location of each file as a pathname.

Map documents and pathnames

A pathname is the list of folders that one must traverse to reach a particular file on the disk. A
pathname begins with the drive letter and lists successive folders, each one beneath the previous,
separated by backslashes. The pathname c:\mgisdata\usa\states.shp thus refers to the shapefile
states.shp which resides in the Usa folder, which in tum resides in the mgisdata folder, which is
found on drive C:\ (Fig. 2.2).

The pathname c:\mgisdata\Usa\States.shp is _I C:
termed an absolute pathname because it starts at the

drive letter and proceeds downward to the file, .
When searching for a file using an absolute mgisdata Relative path
pathname, the search begins at the drive level, * !

Absolute path

A relative pathname is used to indicate that a search l l
should be made starting at the current folder Usa MapDocuments
location, rather than from the drive letter. A double

dot indicates movement up one folder. Thus the -—Stzes —-ex_1.mxd
pathname ..\Usa\States.shp indicates a search up -_Cities --ex_2.mxd

one folder and then down into the Usa folder and .-Counties |—ex_3.mxd
thus to the States shapefile. It provides an altemate

route from the MapDocuments folder to States.

Fig. 2.2, Pathnames
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Map documents can store cither absolute or relative pathnames, and the choice is made by the
user creating the map document. By default a map document stores absolute pathnames.
Imagine that the map document ex_1.mxd in Figure 2.2 refers to the States file in the Usa folder.
When the map document is opened in ArcMap, it searches starting at the C:\ drive down through
C:\mgisdata\Usa\States.shp in order to locate and draw the states in the map.

However, what if the user decides to move the mgisdata
folder to another location on a network drive designated = £=F Layers
with the letter F\? Upon opening the ex_1.mxd map '
document in the new location, it searches down the C:\ path

as before but can no longer locate the mgisdata folder or its @

contents. The links to the spatial data are broken, and in B [ shates
ArcMap the States layer will appear with a red
exclamation point (Fig. 2.3). The user can manually locate

the data to fix the links, but this can be time-consuming if Fig. 2.3. The red exclamation

point indicates that the pathname

the document contains many layers. In ArcCatalog one can YOI
tink is broken.

right-click the map document and choose Set Data
Source(s) to fix multiple links more efficiently.

A better solution is to direct the map document to store relative pathnames. In this case the
States pathname is stored as .\Usa\States.shp, and it no longer matters whether the mgisdata
folder exists on the C\ drive, the F:\ drive, or even under Cistudents\projectimystuff. As long as
the relative positions of the MapDocuments and Usa folders remain the same, the map document
can always locate the data it is looking for.

The choice of absolute or relative pathname depends on the situation. If the map documents will
always refer to a central data server folder that all users on a network have access to from many
different computers, and the users want to transfer map documents from computer to computer,
then absolute pathnames will more reliably locate the data layers. On the other hand, if a user
plans to move the map documents and data together as a unit, then relative pathnames work
better. The map documents on the CD that comes with this book store relative pathnames, so that
the links to the data layers continue to work no matter where you install the mgisdata folder.

VERY IMPORTANT TIP: Pathnames, including the names of map documents and spatial data
sets, should not contain spaces or unusual characters such as #, @, &,*, etc. Use the underscore
character to create spaces in names if needed. Although ArcCatalog and ArcMap allow spaces
in names, the spaces create problems for certain functions. Thus, it is wise to avoid them entirely.

ArcMap windows and menus

The ArcMap Graphical User Interface (GUI) packs a lot of functionality into a deceptively simple
space. This section introduces the primary features and functions of the interface, including the
menus, toolbars, and layout of the ArcMap main window.
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The menu bar

The menu bar usually lies at the top of the window and includes groups of commands in several
categories (Fig. 2.4). The Customize function allows the user to add commands to the menu bar.
Many functions can also be accessed using buttons in the toolbars, The menu bar can be torn off
its location and moved to another site in the GUI, or even off the GUI entirely.

The toolbars

The toolbars contain buttons that perform
actions, or buttons that convert the mouse
cursor into different types of tools (Fig.
2.4). For example, the Add Data button
launches a dialog box to add layers to the
map, and the Identify button converts the
cursor into a tool for getting information
about individual features in the map (Fig. -~
2.5). Toolbars are organized into groups of related tasks, such as the
Zoom/Pan toolbar, the Editing toolbar, the Layout toolbar, eic.

Fig. 2.4. A menu bar (top) and a toolbar (bottom) W

Like the menu bar, toolbars can be torn from their locations and docked
somewhere else, including off the GUL Buttons can be added to
existing toolbars, and the user can create entirely new toolbars for

favorite sets of commands. Fig. 2.5. Some
buttons

Context menus
A context menu appears when the user right-clicks certain L
objects, such as layer names, symbols, field headings, and e -
more (in contirast to the more usual /efi-click for most

operations). The menus that appear will depend on the object 3 [ Hospitals
clicked, and even the situation at hand. To determine whether 3
an object has a context menu, simply right-click it to see if one B O Schods
=
appears. 5] Taurist Spots ‘
" .

S
The Table of Contents e , ?
The Table of Contents window lists the data layers and tables B ] ey Rosds '
that have been added to the map (Fig. 2.6). It also provides == Quyral Intersta

access to several functions. The window has three modes:
Display, Source, and Selection. In Display mode, only the
layers are listed. In Source mode, the layers are organized into
their home directories, and additional nondisplaying objects
such as tables are listed as well. The Selection tab shows the _
selection status of each layer, i.e., the number of features that Fig. 2.6. The Table of
have been selected using a query, as discussed in Chapter 6. Contents

Clicking the tabs at the lower right corner of the Table of

Contents determines the current mode.
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» Checking and unchecking the boxes by each layer turns the layer display on and off.

3 In Display mode, you can control the order in which layers are drawn by clicking the
layer and dragging it to a new position in the list. The map is drawn from the bottom up.
When adding layers, ArcMap automatically puts polygon layers at the bottom, then line
layers, then point layers. The order can be important. If a polygon layer appears above a
point layer in the list, then the points will be obscured by the polygons being drawn on

top of them.

» The Table of Contents shows the symbols being used to draw each layer, and also
provides access to the menus and tools that manage the symbols. Clicking and right-
clicking a layer symbo! launch different ways to modify it.

% Double-clicking a data layer name opens its Layer Properties window.

» Right-clicking a layer name in the Table of Contents produces a contest menu which
provides access to many functions and properties associated with the layer.

1

ap sca

= & South Dskota ’ Toolbars
i = O Hospials ' . : Map —
+ { : e in Layout view
= [ Tourist Spats : ; . RS :
*
= Towns
4
Major Roads
B M Rivers
= Lakes
=
£ B Counties
[

g £ us States
5d_bound
B
= stal

Table of
Contents

Map units
display

Fig. 2.7. Layout and features of the map window in ArcMap

The map window

The map window is the main display area (Fig. 2.7). Data in the window are organized into
groups called data frames, which are boxes containing views of the data in the group. The map
window has two view modes: Data view mode and Layout view mode. In Data view, only a
single data frame is displayed. Layout view is a picture of what the map document would look
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like if printed, and it shows all of the data frames on the page, along with titles, scale bars,
legends, and any other map information that has been placed on the page. The ArcMap interface
in Figure 2.7 shows a map with two data frames in Layout view.

Data frames

Data frames contain layers and tables to display and analyze together and are used to help
organize the map. A map document can have multiple data frames. The map document in Figure
2.7 has two: a frame called South Dakota angl another called US States. The US States frame is
outlined with blue squares because it is currently the active frame. All commands and actions,
such as Adding Data, occur in the active frame. When the map window is in Data view, only the
active frame is visible. In Layout view, all the frames are visible,

Data frames have properties, just like other objects in ArcMap. Frame properties include the
coordinate system, size and position, borders, rules for labeling features in the frame, and others.
The chapters ahead explain more about data frame properties.

The coordinate system of a data frame defaults to the coordinate system of the first data set
loaded into it. The coordinate system can also be set explicitly. ArcMap practices on-the-fly
projection, meaning that every data layer in the frame is automatically reprojected to the frame
coordinate system so that they will all display together.

Layers and layer files

Once a data set, whether a shapefile, feature class, coverage, or g
table, is added to ArcMap, it becomes a layer and is listed in the  |¥ £ Layers ) _
Table of Contents. Each layer has properties that control how it B M vegetation szlection
is displayed and used. Some of these properties you have .
already encountered, such as Map Tips and the symbols used to = Vegitgﬂﬂ:wE
display the layer. You will learn others soon, such as labeling =
properties, relationships with other tables, and whether any CRA
features have been selected as the result of a query. HFL
TAA
Many layer properties are accessed by right-clicking the name of
the layer and choosing Properties from the context menu. The TR
Properties dialog box has many tabs, each of which provides the TOH
interface for setting layer properties. For example, the General TR
tab specifies the name of the layer, whether it is currently TS =
visible, and at what range of scales it is displayed. Many of £ W vegetation B
these options can also be set elsewhere. The Symbology tab CROMR_COY
provides detailed control of the colors, sizes, and shapes of lo-19

symbols being used to draw the layer.

Layers reference a specific data set such as a shapefile; however
they are not exactly the same as the data they reference. For one
thing, the Table of Contents may contain several layers that

reference the same shapefile. The Table of Contents in Figure Fig. 2.8. Several layers all
2.8 contains three layers all based on the same vegetation feature  pased on the same
class. The lowest layer displays the vegetation in terms of its vegetation feature class.

tree crown cover percentage, one of the fields in the attribute

70




Working with ArcMap

table. The middle layer uses a different field, the cover type or species, to display the polygons.
The top layer is based on a query, and contains only the ponderosa pine (TPP) polygons.

One use of layers is to present multiple views of the same data based on different fields, as shown
in Figure 2.8. Another use is in processing data when only a subset of features is needed fora
command. The vegetation selection layer could be passed to a command or tool, which would
then only act upon the ponderosa pine polygons instead of all the polygons in the feature class.

The current settings and properties of a layer may be stored in a layer file. These files include a
pathname specifying the name and location of the data set, plus all of the properties that have
been set for the layer. Layer files have many uses, such as storing symbols and labels for use in
multiple map documents or keeping a subset of selected features ready for use over and over in
different commands.

Working with symbols and styles

Symbols come in three types: marker symbols for point data, line symbols for line data, and fill
symbols for polygon data (Fig. 2.9). Each type has its own basic properties to set.

Marker symbols have a symbol, a size, a color, and an angle. Line symbols have a symbol, a
color, and a thickness. Polygon symbols have a fill style, a fill color, an outline thickness, and an
outline color. The fill can be a solid color, or it can be patterns such as stripes, or even pictures
made from bitmap files.

The Symbol Selector allows the
user to select an existing

symbol, use it as it is, or modify I
its properties to suit specific
needs, such as changing its Adrport Expressway

color (Fig. 2.9). For example,
the Expressway symbol could
be given a different color and
line width.

Pirk 500 Year Flood
Many symbols come with Overlay
ArcMap in addition to the basic
“ones that appear in the Symbol
Selector. The user can load
additional symbol sets and
modify them to suit specific
applications, or ¢create entirely
new symbols and symbol sets.

Fig. 2.9. Examples of symbols: a marker for airports, a line
symbol for expressways, a pink solid fill symbol, and a 500
Year Flood patterned fill symbol. Once a symbol is chosen
in the Symbol Selector, you can modify its properties.
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The Help system

ArcGIS includes extensive help files with a wealth of important information. Help is requested
from the Help entry on the main menu bar. On the left are three tabs allowing the user to search
for information, and the right shows the current entry on display (Fig. 2.10). Four search methods
are available. The Contents tab shows an organized outline of material, much like a library of
books. To view the contents of a book, click the plus sign to expand the entry. The Index tab
contains a wealth of frequently used entries. Typing a word in the box on top causes the window
to jump through the index to the matching word. The Search tab allows the vser to enter a word
or phrase and search the entire Help text. Finally, the Favorites tab can be used to save entries
that are frequently consulted.

]} 4G5 Desktop Help

R} Waloome to AreGIS Dashiop Help : _W_e!come o ArcGIS

& Copyright irfomation -7 Deskiop Help

& GIS glossary © ArcGIS Deskiop applications e
B What's new in AGIS Deskiop 9.1 . Getting help » itional resources
& What was new in Arei5iS Deskiop -
@ Gatting started

Arc¥ap—iets you view, create, and
active ‘query maps, as well as edit data.
adding I ¥ Get started with ArcMan

sdding backgiounds ) b Learn how to edit n ArcMap

2dding borders @ Geoprocsssing tao reference : .

annotation gioups in @ 8uiding 3 geodatabase -ArcCatalog—Provides data actess
custonizing in layouts @ Cdiing in ArcMap - and spatial data management tools,
gele.““g. @ Geocoding “including the reading and creation of
bpic.ting & 1 } metadata.

b Get starfed with ArcCatalog

giving focus to

Fig. 2.10. ArcGIS Desktop help: (a) getting help, (b) the Help window showing the
Contents tab, (c) the Index tab

Map scale concepts

What is map scale?

Map scale is a measure of the size at which features in a map are represented. The scale is
expressed as a fraction, or ratio, of the size of objects on the page to the size of the objects on the
ground in real life. Because it is
expressed as a ratio, it is valid for

: i 25cm
any unit of measure. So fora _
common U.S. Geological Survey B
topographic map which has a scale 100,000 x o

of 1:24,000, one inch on the map
represents 24,000 inches on the

x=250,000 cm or 2.5 km

ground (or one meter represents <

24,000 meters on the ground, and 2.5 cm

so on). Imagine a map made to the - ; :

scale of 1:100,000. You can use Fig. 2.11. Solving for the actual size of a lake

the map scale and a ruler to
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determine the true distance of any feature on the map, such as the width of a lake (Fig. 2.11).
Measure the lake with a ruler, and then set up 2 proportion such that the map scale equals the
measured width over the actual width (x). Then solve for x. Keep in mind that the actual width
and the measured width will have the same units. You can convert these units if need be.

Often people or publications refer to large-scale maps and small-scale maps. A large-scale map is
one in which the ratio is large (i.e., the denominator is small). Thus a 1:24,000 scale map 18
larger scale than a 1:100,000 scale map. Large-scale maps show a relatively small area, such as a
quadrangle, whereas small-scale maps show bigger arcas such as states or countries.

Scale with GIS data

When data are stored in shapefiles or other spatial data
formats, they do not have a scale, technically speaking,
because only the coordinates are stored. They acquire a
scale once they are drawn on the screen o1 0n a piece of
paper. ArcMap has a scale box on the main toolbar that
reports the current scale of the map on the screen (Fig.
2.12), and it updates every time the zoom scale

i

Fig. 2.12. The scale box in
ArcMap shows the current
scale of the map on the screen.

changes. Likewise, you can determine the scale of a
map to be printed or set a specific scale to print to.

However, the concept of scale does apply to GIS
data, in the sense that most data layers have an
intrinsic scale at which they were created. The map
in Figure 2.13 shows congressional districts in pink
and the state outlines in thick black lines. Notice
how the state boundaries are more angular and less
detailed than the districts because they were digitized
at 2 smaller scale. Thus, although it is possible to
take small-scale data and zoom in to large scales, the

accuracy and detail of the data will suffer. The
original scale of a map or data set is thus an
important aitribute, and it should be included when
creating metadata for layers.

Fig. 2.13. These two layers
showing Massachusetts originated
from maps with different scales.

One should exercise caution in using data at scales

very different from the original. When selecting or creating data, it is also important to use data
that are appropriately scaled for the analysis. Zooming into a data set may give a false impression
that the data are more precise than they actually are. A pipeline digitized from a 1:100,000 scale
map, for example, has an ancertainty of about 170 feet in its actual location due just to the
thickness of the line on the paper. Displaying the pipeline on a city map at 1:60,000 might look

fine, but zooming in o 1:2000 would not help at all should you desire to locate the pipeline by
digging.

From looking at Figure 2.13, one might conclude that if is desirable to always obtain and use data
at the Jargest possible scale. However, large-scale data require many more data points per unit
area, increasing data storage space and slowing the drawing of layers. Every application has an
optimal scale, and little is gained by using information at a higher scale than needed.
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Reference scale

Data frames have a property called the reference scale, which stipulates the scale for which the
layers are designed to be displayed (Fig. 2.14a). When placing symbols and labels on the map,
you naturally give the

symbol's their most — Fig. 2.14. (a) The reference
aestheﬂcally pleasing size I - _“—r‘ﬂ' o MN":"‘J ."*""“_ " i scale sets the proportional size
relative to the current o el 1 o of the features and their text,

map scale. However,
because symbols
normally remain the same

£y {b) If the reference scale is not
."' . hrt v LT smqu +

3 m_ﬂm;ﬂw; e set, the symbols will always

_ & m.,m,‘:"w.,.p.%;"'" appear the same size. (¢} If

size as the scale changes, the reference scale is set, then

at some zoom levels they ) zooming in or out changes the

appear too large, while at a ~ i gewn | size of the text and symbols in

others they appear too proportion to the features.
small (Fig. 2.14b).

If the reference scale is
set, then the symbols will
get larger or smaller as
the zoom scale changes, |

Just as the features do ST e o {
(Fig. 2.14c). You can set e _egman- i
the reference scale, clear b | c | l

it, and antomatically
Zzoom to it.

Chancellcﬁ

Zoom in—reference scale not set  Zoom in——reference scale set

TIP: Be sure to understand the difference between the terms map scale, reference scale, and
visible scale range. Map scale determines the ratio of features on the map to features on the
ground. The reference scale controls the sizing of symbols and text when zooming from one map
scale to another. The visible scale range determines the range of scales at which a layer will
appear.

Labeling concepts

Labeling involves taking an attribute of a feature, such as its name, and placing it on the map
close by. ArcMap provides three basic types of labeling. You can place interactive labels one at
a time, or automatically label many features using dynamic labeling, or take precise control of
labeling by using annotation.

Interactive labels

Interactive labels are constructed by the user one at a time, and they can be used to label map
features or provide titles and supporting text for a map layout. One labeling method involves
placing text interactively on the map in one of three ways: as a plain text graphic, as a callout
box, or splined along a line. A callout places text in a box with a pointer to indicate the feature of
interest. Splining causes labels to follow along a feature such as a road or creek. Alternately, you
can label a feature using the value from a field in its attribute table. All interactive labels remain
on the map as graphic elements, unless you decide to select and delete them.
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More complex text can be constructed using the wrapped text tools. The text is placed inside a

shape defined by the user, and rudimentary control of margins and columns is provided, as well
as background and border options. If the wrapped text box changes shape, the text inside is

automatically reformatted to fit.

Dynamic labels

Dynamic labels are created from an attribute and are actively managed by ArcMap as you turn
layers on and off, zoom in and out, etc. Every time you redraw the map, ArcMap redraws the
labels. It optimizes the display by omitting overlapping labels. Thus the number of labels

displayed can vary, depending on
the zoom scale and label size.

Creating dynamic labels involves the & the same way.

specifying the label field in the

Layer Properties menu, setting

options for how they appear, and

turning them on (Fig. 2.15).

Choices include the following:

» Setting options that

control the size, font, and

color of the labels.

» Setting priorities for where

they are placed.
» Adopting guidelines to Fig. 2.15. Set the labeling properties of dynamic labels
resolve overlap conflicts using the Labels tab in the Layer Properties window.

between labels.

» Specifying different classes of labels. For example,
large cities could have a bigger label and take priority
over smaller cities.

¥ Using the data frame properties to control which
layers have priority over others, such as always
labeling states before cities.

» Specifying that labels be displayed only at a range of
scatles, just as for layers.

The Placement Properties help to manage the overlap and
optimization of the labels to give the best possible result.
Points, lines, and polygons have different placement options.

Point label overiaps are resolved by offsetting the label from
the point, while putting as many labels as possible in the
preferred location.

Line labels can be placed several ways: they can be placed
horizontally or vertically at the middle or ends of the line.
You can also spline text along a linear feature, placing it
inside, above, or below the line (Fig. 2.16).

! b
/ il il

Fig. 2.16. Line labels may be
splined along features such as
these creeks. Polygon labels

may be horizontal or straight

with the long edges.
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Polygon labels may be forced to be horizontal, or the software can try to place them at the same
angle as the polygon’s longest boundaries to maximize the fit (Fig. 2.16). In addition, the user
can request to omit labels that would extend beyond the borders of the polygon.

Duplicate label options are used in situations such as one street composed of many blocks. You
can control whether a label is placed for every block, or only one per street.

Finally, the Conflict Detection options can handle priorities for different layers. Label weights
control which layers take priority; for example, states might have a higher priority than cities and
be preferentially labeled in case of a conflict between the two. Feature weights specify the
layers whose features cannot be overlapped by labels. For example, labels from cities should
probably not obliterate markers for Superfund sites. Finally, label buffers prevent new labels
from encroaching on the edges of existing labels.

Because the actual labels placed vary, depending on scale and symbol size, printing maps based
on dynamic labels can bring surprises. What shows on the screen does not necessarily appear the
same way on the map. The Print Preview option shows the printed map and labels as they will
appear. For many purposes a few extra or missing labels do not matter. If they do, however,
converting labels to annotation provides greater control over label placement.

Annotation

Annotation provides precise control of each label. Ordinary dynamic labels can be converted to
annotation. The labels that fit on the map are automatically placed, and the overlapping labels are
directed to an overflow window. From this window you can work with the labels individually to
place them exactly as needed. Annotation always appears in the same place and at the same size
regardless of printing or zooming changes. Annotation may be stored in three ways.

» You can store it in the map as simple text.

» You can store it as a feature class in a geodatabase and use it in other map documents.

% You can store it in the same geodatabase as the features linked to it—of course the
features must then be in a geodatabase and not in a shapefile or coverage. Feature-linked
annotation is automatically created, moved, and deleted as the features are edited, but it is
only available to ArcEditor or Arclnfo users, not to ArcView users.
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Summary

»

ArcMap provides a fully customizable graphical user interface (GUI) composed
of menu bars, toolbars, windows, and context menus.

Map documents store references to layers and information about them, such as
how to draw them. The actual data exists outside the document and may be used
by many people.

Map documents may store either absolute or relative pathnames for data files.
Absolute pathnames work better when the data will always be in the same place
for every user. Relative pathnames are best if the data will be moved about.

The Table of Contents lists the available data layers and provides control for the
order of drawing, and through context menus it gives access to properties and
commands associated with each layer.

Data frames contain layers to be drawn together, and they also have properties
including the coordinate system and the reference scale.

Data layers have multiple properties covering issues such as the source data, the
projection, display, labeling, symbols, and more.

Map scale is the ratio of size in the map to size on the ground. The original scale
of a geographic data set determines the scale of its usefulness.

The display scale controls the range of scales at which a layer appears. The
reference scale of a data frame can be used to control the scaling of symbols and
labels.

Labels can be placed dynamically or as permanent annotation. Annotation may
be stored as text in the map, as a feature class in a geodatabase, or as feature-
linked annotation in the same geodatabase as the features.

VERY IMPORTANT TIP: Pathnames, including the names of map documents and spatial data
sets, should not contain spaces or unusual characters such as #, @, &, *, etc. Use the underscore
character _to create spaces in names if needed. Although ArcCatalog and ArcMap allow spaces
in names, the spaces create problems for certain functions. Thus, it i3 wise to avoid them entirely.

TIP: Be sure to understand the difference between the terms map scale, reference scale, and
visible scale range. Map scale determines the ratio of features on the map to features on the

ground. The reference scale controls the sizing of symbols and text when zooming from one map

scale to another. The visible scale range determines the range of scales at which a layer will
appear.
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Chapter Review Questions
You may need to consult the Skills Reference section to answer some of these questions.

1.

2.

9.

Describe the difference between a data layer and a data frame.
What is a map document, and what types of information are stored in it?
How does ArcMap decide which layers to draw first?

Mary creates a map document and e-mails it to a colleague in another state. He calls and tells
her the document opens but no map appears. Explain what is wrong.

What does it mean if a layer’s check box is dimmed?
Why can different labels appear each time you zoom or pan a layer with labels?
What is the difference between the scale range and the reference scale?

You measure a football field (100 yards long) on a detailed map and find that itis 0.5 inches
long. What is the scale of the map?

Describe the difference between dynamic labeling and annotation.

10. What characters should be avoided when naming GIS files, folders, and map documents?
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Mastering the Skills

Teaching Tutorial

The following examples provide step-by-step instructions for doing basic tasks and solving basic
problems in ArcGIS. The steps you need to do are highlighted with an arrow =>; follow them
carefully. Click on the video number in the Videolndex to view a demonstration of the steps.

= Start ArcMap, if necessary. Navigate to the mgisdata\MapDocuments folder and open
the map document ex_2.mxd.

=» Choose Save As from the File menu and save your own copy of the map document
under a new name such as ex__2mine.mxd. Save it frequently as you work.

TIP: The names of map documents, spatial data sets, and folders should not contain spaces or
unusual characters such as #, @, &, *, etc. Use the underscore character _ to create spaces in
names if needed. Although ArcCatalog and ArcMap allow spaces in names, the spaces can create
problems for certain advanced functions. Thus, it is wise to avoid them entirely.

Working with the map display

First, let’s briefly review some of the techniques for zooming and panning that we learned in
Chapter 1.

1=» Use the Zoom In tool to draw a box around the
lower part of the large lake in central South Dakota
(Fig. 2.17).

1= Hover the cursor over the lake for a moment until
its name appears.

I.  What is the name of this lake?

Fig. 2.17. Zoom to this lake

2, What is the function called that causes the lake name to
appear?

=¥ Use the Pan tool to drag the two small towns near the bottom part of the lake to the
center of the view.

1= Use the Fixed Zoom In tool to zoom in. Keep clicking the tool until the schools
appear on the map.

3. Atapproximately what scale do the schools appear?

1> Click the Fixed Zoom Out tool ONCE to zoom back out.

4. What is the scale now? Make a guess what the minimum scale for the
school display is set to.
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2=» Right-click the Schools layer in the Table of Contents and choose Properties from
the context menu.

2=>» Click the General tab and read the minimum display scale.

5. What is the minimum display scale of the Schools layer?

2=» Click the button to Show Layer at All Scales and click OK.
2=» Use the Full Extent button to zoom to all of South Dakota again.

Now the schools are displayed for the entire state.

TIP: You can also set/clear the range scale by right-clicking the layer name in the Table of
Contents and choosing Visible Scale Range,

3=> Use the Previous Extent button to return to the close-up of the Pierre area.

Now notice a curious thing: north of the two towns (Pierre and Ft. Pierre), two schools show up
in the middle of Lake Oahe. This seems very odd, unless they mean schools of fish.

3=¥» Click on the Identify button and click on each school in torn.

6. What are the schools’ names?

Each school’s name is followed by the term “historical”, so probably these schools were built and
used prior to the dam that created Lake Oahe.

4=> Close the Identify Results menu.
4=» Use the Forward Extent button to return to the display of the state.

4=¥ Click the Find button. Fill out the dialog box to search for Meadowbrook in the
NAME field of the Schools layer.

4= When it finds the school, right-click on the school name and choose Zoom To.

4=» Right-click the school name again and choose Flash to locate it. You may need to
move the Find dialog box to see the feature flash. Repeat if needed.

7. To what urban area does Meadowbrook School belong?

5« Close the Find dialog box.
5=» Choose View > Bookmarks > Rapid City from the main menu bar.

5=> Click the Measure tool and use it to determine the length of Rapid Creek inside the
urban area of Rapid City (inside the blue boundary).

5=» Instead of the default meters, click on the Choose Units button and set the units to
miles. Measure again.

8. What is the length of Rapid Creek inside Rapid City, in miles?

6= Click the Measure Feature button on the Measure tool.
6=>» Change the area units to acres.
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6= Click on the Rapid City urban area shown as the blue polygon.

9. What is the area of Rapid City, in acres?

Using data frames

Now we will learn some things about data frames. First we will examine the map in Layout view,
rename the existing data frame, and add a new one.

7=» Close the Measure tool, and then click the Layout view icon in the lower left of the
display area to switch from Data view to Layout view.

74 Click on the Layers data frame name; then click again and type in a new name for it,
Rapid City. Click Enter.

7+=¥ Click the minus sign in the box next to the data frame name to collapse the list of
data layers in it.

7= Choose Insert > Data Frame from the main menu bar.
7=> Rename the new frame South Dakota.

The new data frame appears with a set size in the middle of the page. It is highlighted with blue
handles, indicating it is the active frame. The active frame is also shown in boldface type in the
Table of Contents, Next, resize both frames so they do not overlap each other on the page.

8=> Place the cursor inside the South Dakota frame; then : —— |
click and drag it to the lower right, slightly off the page. ' |

8=> Click once inside the Rapid City frame to make it the
active frame. Place the cursor over the lower left or
right corner, and click and drag to resize the frame to
occupy only the top half of the page.

8> Move and resize the South Dakota frame until the page e
appears similar to the one shown in Figure 2.18. oY

9=» Make sure that the South Dakota frame is the active
frame.

9> Click the Add Data button. Navigate to the
mgisdata\Sdakota\southdakota geodatabase and choose
the state feature class. It appears in the data frame.

9=> Switch back to Data view by clicking the world icon

(Fig. 2.19), or choose View > Data view in the main
menu bar,

Fig. 2.18. Layout view

Data view
Layout view
Refresh view

You will use this data frame to create a location map for Rapid Fig. 2.19. View buttons

City. First, however, notice that the state appears elongated in the

east-west direction. This elongation provides evidence that the data layer is stored in geographic
data units, that is, latitude-longitude. Let us examine the coordinate system in a little more detail.

10=> Right-click the state layer name in the Table of Contents and choose Properties;
then click the Source tab to see the projection information.
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10. What is the coordinate system of this data set?

By default, the data frame adopts the coordinate system of the first data set loaded into it. Any
other data sets loaded now would be drawn in this same coordinate system, no matter what other
coordinate system they may have.

10=» Look at the map units display at the bottom of the ArcMap window and verify that
the units are shown in degrees of longitude and latitude.

492523, ..ﬁﬁf.'f_‘ia:._

The map units displayed have also defauited to the units of the first coordinate system—degrees.
These display units can be changed.

Although data are commonly stored in a geographic coordinate system (GCS) with units of
degrees, the distortion inherent in a GCS makes it a poor choice for a map, and professional
cartographers avoid using GCS in maps for this reason. We will now set the map projection of
the frame. Afterward, the GCS units are projected on the fly to whatever coordinate system is
chosen for the data frame.

[1=» Close the Layer Propertics window.

11=¥» Right-click the South Dakota frame name, and choose Properties from the context
menu.

11=» Click the Coordinate System tab, and verify that the frame coordinate system is the
same as the state coordinate system.

11> In the box showing the coordinate system tree, click the following links to find the
coordinate system desired: Predefined > Projected Coordinate Systems > State Plane
> NAD 1983 > NAD_1983 StatePlane_South _Dakota North FIPS 4001. Click OK.

Now that the data frame has this coordinate system, any other data layer loaded into the frame
will be reprojected to match it. Next, you will set up an extent rectangle to show the location of
Rapid City in this frame. This trick is another data frame property.

12> Open the South Dakota frame Properties window, and choose the Extent
Rectangles tab.

12= Click the Rapid City frame in the list to the left, and click the double arrow to place
it in the list to the right,

12=¥ Click the Frame button and choose the border by clicking on the drop-down list
next to the sample. Select the 4.0 Point ling symbol. Click OK in both boxes.

12> Use the Zoom In tool to zoom in as far as possible to the state without cropping any
of'it.

12=>» Switch to Layout view to verify that the border is shown. Extent rectangles only
appear in Layout view.

Labeling features interactively

We need to add a few labels to this map. We can do this easily using the text tool in the Drawing
toolbar.

13=» Make sure that South Dakota is the active frame and return to Data view.

82




Working with ArcMap

13> Click the New Text tool on the Drawing toolbar. The black triangle indicates that

more versions of this tool are accessible by clicking the drop-down arrow.

13=¥ Click inside the state; then type the name South Dakota. Press Enter.
13=> Click once on the text to select it.

Notice the blue dashed line that appears around the text, indicating that it is currently selected and
will be affected by changes in its font or other properties.

13=» Use the drawing toolbar buttons to set the font size to 28 and make the text Bold.
Click and drag the text to center it inside the state.

TIP: To delete text, click the black arrow on the Drawing toolbar, click the text to select it, and
press the Delete key. You can also use the black arrow to draw a box around many text boxes, or
hold down the Citrl-key to select multiple text boxes for deletion.

14=» Use Add Data to add the feature class urbanarea from southdakota.mdb to the
South Dakota frame. If necessary, use Find to locate Rapid City.

14=¥ Click the drop-down arrow on the Text tool and choose the
Callout text button. Click on Rapid City and drag slightly to the
lower right to create the label.

14=» Type in the name Rapid City and press
Enter. Select the new label. Adjust its
location and pointer end if necessary (Fig.
2.20). Also adjust the South Dakota label
it needed so that both can be clearly seen.
(Make sure the Select Elements tool is
!T selected on the drawing toolbar to move
the labels.)

14=> Turn off the urbanarea layer by clicking
its check box.

14=>» Switch to Layout view to see the
Chafgles_ Y W Fig. 2.20. Labeling the state

14=>» Use the Layout Zoom In tool to zoom in to the South Dakota frame.

Notice that the South Dakota label has run over the edge of the state, and the Rapid City label is
so enlarged that the pointer is not even visible. This happens because the font sizes remain the
same with respect to the screen, but the state became smaller when you switched to Layout view.,

Setting the frame’s reference scale will fix the label sizes so they remain the same relative to the
state size.

15=¥» Go back to Data view.

15=> Right-click the South Dakota frame and choose Reference Scale > Set Reference
Scale from the menu.

15=» Switch to Layout view again. This time the labels are scaled down along with the
state.
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The multiline text tools are useful for placing paragraphs on a map document. Several different
shapes can be chosen, including rectangles, circles, and polygons. The size and shape of the text
boxes can be adjusted, and the text inside will automatically be wrapped to fit.

16=>» Click the Zoom Whole Page button on the Layout toolbar,

16=» Click the New Rectangle Text button on the Drawing toolbar and click and drag to
create a rectangle in the empty part of the page, and then release the mouse bution. A
dotted box with “Text” inside it will appear.

16=» Double-click in the text box to open its Properties, and click the Text tab. Entera
paragraph in the box, saying whatever you like, without pressing Enter.

16=>» Click the Frame tab and choose a border for the text.

16=» Click the Columns and Margins tab. Leave the margins as is, but set the number of
columns to 2. Click OK to close the text Properties box.

16=>» Adjust the rectangle size by clicking and dragging its corners. Change the font or
other properties of the text using the Drawing toolbar or by double-clicking on the text
again to edit its propertics.

16=» While the text box is still selected, press the Delete key to get rid of it.

Next we will change symbols and create labels for the schools in Rapid City.

17=» Return to Data view. It will show the South Dakota frame since that was the most
recent active view.

17=» To switch frames while in Data view, right-click the Rapid City frame name and
choose Activate from the context menu.

17=>» Click the plus sign next to the Rapid City frame to expand its contents again.
17=¥ Click the Schools symbol to launch the Symbol Selector. Choose the symbol

School 2, click on the color box and select a red color from the palette, and change the
symbol size to 16 pts. Click OK.

First we will demonstrate using the labeling tool to label features individually. Later we will
create dynamic labels.

18=>» Choose the Label tool from the text tool set. This tool uses the
display field set in the layer properties to label the features clicked.
The Label Tool Options window appears.

18=> Keep the default options to automatically find the best label
placement and to use the label properties set for the layer.

18 Click inside the blue area and watch the Rapid City label appear. Use the drawing
toolbar to change its font size to 14 and move it to a better location, if needed.

TIP: To delete a newly added label, press the Delete key while the {abel is still selected.

18=> Click somewhere on the orange background (Pennington County).
No label appears when you click the county. It is likely that the “best label placement” for the
label is the middle point of the county, which does not show up in this view. Hence no label

appears. Adjust the label placement options to solve this problem.
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19> Change the labeling option to Place label at position clicked. (If you have already
closed the Label Tool Options menu, click the Label tool again to open it.)

19> Click the orange background again, and the county label will appear. Adjust its
font to 24 points and move it to a better location if desired.

19=» Click on a section of Rapid Creek to label it. Adjust the size, font, or location if
needed.

192> Click on the major highway running east-west near the top of the map.

Notice that when you click the highway, only an empty label box appears. You might need to set
the display field for the layer.

20> Close the Label Tool Options window.

20=>» Open the Major Roads layer properties and click the Labels tab. The Label field is
currently set to DESCRIP. Close the Properties window,

20> Use the Identify tool to click the highway now. Notice that its DESCRIP field is
blank, which explains the labeling problem. SIGN1 looks like a better field for
labeling. Close the Identify Results window.

20=» Open the Label tab in the Properties window again, and change the Label field to
SIGNI1. Click OK to close the Properties window.

20"¥ Click the Label tool again, set it to place labels at the position clicked, and click on
the highway to create a new label.

TIP: If you still have trouble making a label appear, be sure to click exactly on top of the
highway symbol. The Map Tips option is turned on for this layer, so it may help to wait until the
tip appears, and then click to place the label.

20=» In the Label Tool Options menu, change the second option to Choose a Style.

20> Click the Interstate Highway symbol from the list that appears. Label the highway
again,

20> Choose the U.S. Route symbol and label the smaller road heading south from town.
20> Close the Label Tool Options window.

TIP: Simple labels, text boxes, and graphics are collectively termed Elements. To Select All
Elements or Unselect All Elements, use the functions in the Edit pull-down menu on the main
menu bar.

Creating dynamic labels and annotation

These labels we have created are simple graphics placed on the screen. Now you will learn how
to create dynamic labels for features based on one of their attribute fields and convert them to
annotation.

21> Right-click the Schools layer and choose Propertics from the context menu; then
click the Labels tab.

21=¥ Check the Label features box. Verify that NAME is the Label Ficld.
21=¥ Increase the size of the text to 12 pt. and make the style Bold. Click OK.
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Notice that some of the schools may not have labels because they overlapped with names of other
schools. The Labeling toolbar offers several convenient functions for working with labels,
including viewing unplaced labels.

22« Right-click the gray menu area at the top of the window, and choose the Labeling
toolbar from the kist.

22=>» Click the View Unplaced Labels button to show the missing labels, which appear
red. (If you don’t see any unplaced labels, click the Fixed Zoom Out tool once or
twice until they appear.)

22=» Zoom into the northeast part of the city between Rapid Creek and the interstate.
Notice how more school labels appear now that we have more space.

22> Use the button to return to the previous zoom extent.

Now let’s experiment with some label placement options.

23=>» Open the Layer Properties for Schools to the Labels tab
and click the Placement Properties button.

Prefer Top Center, all
allowwed

23=¥» Click the Placement tab, if necessary. Notice the graphic
indicating the placement preferences.

23=» Click Change Location and find the Prefer Top Center, all Fi 0 221

allowed icon (Fig. 2.21). Click it to select it and click OK. T
The matrix in Figure 2.21 represents a set of rules for placing the labels. The white space in the
center represents the point itself. The most preferred label location is the top center, designated
with a 1. The boxes labeled 2 are second in priority, and the 3’s show the least desirable tocation.
A zero in a box would indicate that labels must never be placed there.

23=> Click the Conflict Detection tab, and set the buffer distance to (.25 (units are a
fraction of the label height). This option will suppress labels within this distance of
each other for a cleaner-looking map. Click OK.

23=>» Change the font size to 10. Click OK. See the changes.

TIP: Turn labels on and off for a layer by right-clicking the layer name in the Table of Contents
and choosing the Label Features option. If the menu choice is checked, the labels are on, and
choosing it will turn them off. If unchecked, choosing it will turn them on.

Before we convert the labels to annotation for the finishing touches, let’s label Rapid Creek again
with a symbol which angles along the creek.

24=» Select and delete the previous label(s) for Rapid Creek.

24+ Open the Layer Properties for the Rivers layer and click the Labels tab.

24=¥» Check the box to turn on the labels.

24=» Change the font symbol to dark blue italic. Leave the other options as they are.
24=¥ Click the Placement Properties button and click the Placement tab.
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24=> Fill out the boxes as shown in
Figure 2.22 to place labels
parallel to the lines and above or
below them, with a 10-meter
offset, at the best location, and
removing duplicate labels. Click
OK and OK.

Now we will convert the text to annotation
for the final touches. In order fo try out the
entire process, the schools should have
several unplaced labels.

25=» Click the Fixed Zoom Out
button until at least two of the
schools show as unplaced labels.

25 Right-click the Rapid City data

frame and choose Convert Labels
to Annotation.

Annotation is created for an entire data frame
rather than for single layers. Notice that both
Schools and Rivers are listed for conversion,
since both of them currently have dynamic Fig. 2.22. Label placement options for lines
labels. We only want to create annotation

for Schools, and so we must turn off the labels for Rivers.

76=» Cancel the Convert Labels to Annotation window, right-click the Rivers layer, and
uncheck Label Features.

26-¥» Open the Convert Labels to Annotation window again and fill the button to create
annotation in the map.

269 Choose to create annotation only for the features in the current extent. We don’t
want to label every school in the state.

26= Keep the box checked to convert unplaced
labels to unplaced annotation. These labels will e T

be put in an overflow window for individual | west Junior High Sehaols Anno
placement later.

26=>» Click Convert to create the annotation.

View the new annotation. It looks similar to the dynamic
fabels, but the labels are now individually adjustable. If you
had unplaced labels, they were put in an overflow window
(Fig. 2.23). We can place these labels manually.

27 In the overflow window, right-click the first , :
Jabel and choose Flash Feature. Repeat if needed . .
until you see the school flash. (You may need to Fig. 2.23. Manue}lly placing
move the overflow window to see the flash.) overflow annotation

po il
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27-¥ Right-click the school name again and choose Add Annotation, The label is added
to the map. The light blue dashed line around the name indicates that it is currently
selected.

27> Adjust the newly added position to fit. Select and move other school names if
needed.

One benefit of annotation is customizing the label, Look at the long name for the South Dakota
School of Mines and Technology. It would look better to call it by its nickname, SD Mines.

28=) If the South Dakota School of Mines is in the overflow window, add it to the map.

28> Select the school name, and then double-click inside the dashed box. A text dialog
box will appear.

28=>» Replace the text with SD Mines.

28 Click the Change Symbol button, and change the color of the text to blue, to
distinguish the college from the K—12 schools. Click OK and OK.

28=> Find the new label (it is far to the left). Put the cursor inside the label; then click
and drag it to a good location near the school. '

=> Place the remaining overflow labels. To help fit the annotation, adjust the location of
other schools and/or shorten the school names.

TIP: If you are not sure which school is which, use the Identify tool to learn its name. Click on
the black arrow in the Drawing toolbar to continue moving the annotation.

Now that these labels are annotation, they will be scaled in size as the map scale changes.

29> Use the Zoom In tool to zoom into a section of the city with only a few schools.
Although the school symbols remain small, the text becomes large,

Next we will set the reference scale so that both symbols and text are scaled.

29=¥ Use Previous Extent to return to normal.

29> Right-click the Rapid City frame name and choose Reference Scale > Set Reference
Scale from the context menu.

29=» Zoom in again, and notice how this time the symbols increase in size as well.
29=» Return to the previous extent.

TIP: To set an exact reference scale such as 1:24,000, right-click the data frame name, choose
Properties, click the General tab, and type a specific reference scale in the appropriate box.

Some annotation properties can be modified, such as placing a scale range to show it only at
certain scales. It can also be removed from the map if no longer needed.

30=» Open the Rapid City data frame properties and choose the Annotation Groups tab,
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30=» Click the Schools Anno group and choose Properties.

30> Set the option to not show the annotation when zoomed out beyond 1:125,000.
Click OK.

TIP: To remove annotation, click the Annotation Group name to select it, and click the Remove
Group button.

Annotation stored in the map is saved by saving the map document. When creating annotation
you can choose instead to save it as a feature class in a geodatabase, in which case more than one
map document can use it. However, the Editor is then required to modify the annotation.

30=» Click OK to close the Frame Properties window, and click File > Save As from the
main menu bar.

30=» Navigate to the mgisdata\MapDocuments folder for the location, and name the
document ex2_schools. (1t is not necessary to enter the .mxd extension.) Click
Save. We'll use this document again in Chapter 9 to create a layout.

Labeling classes with different label styles

As a final example, we will create Iabels for subsets of
features in a layer. We will label large towns with large text
and smaller towns with small text (Fig. 2.24). This technique
requires creating two classes of labels, setting an expression
which defines each class {population < or > 10000), and
setting the symbol properties for each class.

=» Open the original ex_2.mxd document. Fig. 2.24. Town labels

31"» Zoom into the greater Sioux Falls area as shown in Figure 2.24. Sioux Falls is in
southeastern South Dakota at the intersection of Interstates 190 and 129.

31=» Open the Labels tab of the Layer Properties for Towns.
31=>» Check the Label Features box.
31=» Choose the method to Define classes.

31=>» The current class is Default. Uncheck the Label Features in this class box. Since
we will be creating new classes, we don’t want the default class displayed.

31> Click Add to add a new class.
31=» Name the new class Cities and click OK.

The new class is created, and now all of the buttons and properties in this menu refer to the Cities
class. Next we need to define the members of the class using a selection expression and set the
symbol properties (Fig. 2.25).

32=» Click the SQL Query button and enter the expression [POP100] >= 10000.

32=» Click Verify to check the expression for errors. (If an expression is incorrect, then
no labels may appear.) Click OK and OK.

32+ Check the box to Label Features in the Class.

89




Chapter 2

32=¥» Make sure AREANAME is the label field.
32 Click the Symbol button and choose Country 1 as the symbol for Cities. Click OK.

Now the Cities label class is completely defined. {You could edit other properties for label
placement and scale range, but we won’t do so at this time.) You can always go back to edit them
later. We now create the other class, Villages.

33=> Click the Add
button and name the

new class Villages.
Click OK.

33=» Repeat the steps for
the Villages class just
as for Cities, but for
the labels choose the
symbol Capital and
make it Bold, and
enter the SQL
expression [POP100]
<= 10000. Verify it
and click OK and OK.

33=» When finished
setting the properties Fig. 2.25. Labeling properties window
for both classes, click
OK to close the property sheet and enact the changes.

TIP: To go back and edit properties for a label class later, access the class by chicking the Class
drop-down button in the property sheet and choose the class to edit.

Notice on the map now that Sioux Falls appears in large type and the other towns appear in small
type. You can add as many label classes to a layer as desired. Like other dynamic labels, these
class labels can be converted to annotation and will retain their different sizes in the conversion.

Using the Label Manager

A map with many labeled layers can be cumbersome to adjust if one must keep opening label
properties for each layer. The Label Manager facilitates the control of labeled lavers and makes it
easier to modify the properties of multiple layers.

34=>» Click the Label Manager button on the Labeling toolbar.

The Label Manager (Fig. 2.26) lists all the label classes from all the layers. Notice the two label
classes you just added for the Towns layer: Cities and Villages. Imagine that you want to
temporarily turn off the Villages labels.

34=>» Uncheck the Villages label class but leave Cities checked and click Apply. The
village labels disappear.
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34=» Click the Cities label class in the Towns layer to highlight it. Notice the label
properties appear in the window, similar to the way they appear in the Labels tab of
the Layer Properties menu. You can use the Label Manager to edit the label
properties of your label classes.

34=¥» Change the Cities font color to green.

34=> Click OK when you are done editing the labeling properties.

|
|
J

AREANAME

L[] Defaylt
7 Tourst Spats
f Default
Towns
L1 Defautt
A
Yilagas
-1 Major Rosads
o Default
4 2.0 Rivers
L4 Dafault
- Ushan dreas
LB Defaul
3 Lakes
(o] Drelault
4 £1-[[] Courtias

Fig. 2.26. The Label Manager

Creating a quick printout

Map documents are printed by creating a map layout in Layout view, setting up the map page,
and printing. Chapter 9 covers this process in detail, but we’ll do a quick one now using a
predefined template.

35=» Click the Layout View button to change to layout
view. Soulh Dakota

35> Click the Change Layout button on the Layout
toolbar,

35 Click on the General tab and examine the layout
choices. As you click each name in turn, a
thumbnail view shows what the layout looks like.

35=» Choose the LetterPorirait. mxt template. Click
Finish,

35=> Click on the Full Extent button to view all of
South Dakota again.

36-¥ Click on the Select Elements tool. Click on the
data frame and resize it to look like Figure 2.27. Fig. 2.27. A quick layout
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36=>» Use the Zoom In or Pan tools to adjust the placement of the map inside the data
frame, 1f needed.

36=» Click on the Select Elements tool again. Move and resize the legend, north arrow,
and scale bar if needed to get an attractive map layout.

37=> Double-click on the map title, enter a title in the box, and click OK.
37> Double-click on the text under the scale bar, enter by Your Name and click OK.

38=» To print, choose File > Print from the main menu bar, Notice the preview showing
how the map fits on the printer page.

38=> Click OK to print it {or Cancel if you don’t want it printed).
38=» Return to Data View.

TIP: To change the page layout to Landscape or to change printers, click the Setup button in the
Print window. See the Chapter 9 Skills Reference “Setting up the map page” for details.

TIP: Choose File > Export map to create an image file of a layout in a picture format such as
JPEG or PDF. These images may be placed in word processing or presentation documents, See
the Skills Reference “Exporting a map™ in this chapter for instructions.
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Using symbols and styles

Data layers may be represented with a variety of different symbols. The symbol properties of a
layer control how it is displayed. To demonstrate, we will examine different ways of symbolizing
town features. The towns of South Dakota in the map are currently drawn using a single symbol,
a pink circle. First we will learn to change the characteristics of this symbol. Chapter 4 explainsg
how to create and edit symbols.

39> Right-click the Towns layer and uncheck the Label Features option so the town
labels are no longer being displayed.

39=» Right-click the symbol for Towns in the Table of Contenis. (Make sure to click the
symbol, not the name.) Choose a different color from the palette.

39> Left-click the Towns symbol in the Table of Contents. This action launches the
Symbol Selector, which has more options for changing the symbol.

39> Choose a different symbol from the palette. Experiment with changing its color
and size. Then click OK to make the changes take effect.

<> Examine the new symbols in the map. If they are unsatisfactory, open the Symbol
Selector again and fiddle with the symbol some more.

ArcMap has many other symbol sets that come with it, and new symbols can be created as
needed. Let’s look at some of the other standard symbols available.

40=> Click on the Towns symbol again to open the Symbol Selector,

40=» Scroll down to the bottom of the symbol palette and note that the very last symbol
is called Dam Lock. :

40=» Click on the More Symbols button.
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The menu shows a long list of different styles, which are groups of related symbols used for a
specific purpose. Notice that the first two, yourname and ESRI, are already checked, meaning
that they are being displayed in the palette. You will now choose the Civic style and add it.

40=>» Click on the Civic symbol style, and scroll down to view the new symbols added to

the bottom of the palette, finishing with various symbols for trees. Notice that the
symbols are in alphabetical order by name.

40=>» Choose any symbol from the Civic list to display the towns.

Experiment with choosing different styles and symbols for line and polygon features.

= Click the symbol for the rivers and choose several different line styles from the
default styles and/or add additional styles.

= Click the Counties layer symbol and choose several different shade styles.

This 1s the end of the Tutorial.

=>» Exit ArcMap. Do NOT save changes.

Exercises
Use ArcMap and the data in mgisdata\Sdakota\southdakota.mdb to answer the questions.

TIP: To submit certain answers to your instructor, you must capture an image from the screen
and place it in an answer document. Whenever a question has the statement Capture at the end,
capture the answer by making sure the ArcMap window is active, and simuitaneously press the
Alt and PrintSern keys on the keyboard. This action places the active window on the Clipboard,
and it can then be pasted into a Word or PowerPoint document. For help, ask your instructor.

1. Find the Mount Rushmore Memorial in the interest feature class and zoom into it. Then
answer the following questions.

In which county is it?

What is the name of the river running north of it?

What is the name of the closest town?

How far from the town is the memorial, in miles?

What are the names of the two tourist spots to the immediate northwest of the memorial?

2. Create a road map of South Dakota with the following characteristics:

» Show only the roads and counties. Make the outline CLASS
of the counties medium grey so they are less Rural Interstate
prominent. Urban Interstate
Rural Principal Arterial
Urban Principal Arterial
Fural Minor Arterial

» Change the symbols of the roads to look like this
legend. Use the Expressway symbol for the
interstates and a thick single line for the others. Use
a different color for each one. Capture the map.

LT
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Locate Spink County and zoom into it so that the entire county is visible. Set up the map so
that it displays the schools with purple school symbols, and the county outlines are thick
black lines.

Next, use simple labels to label each of the towns in Spink County. Use a boldface type, and
be sure to adjust the labels for best readability. Capture your map.

Turn off the schools and create labels for the rivers in Spink County, using italic blue text that
follows along the river. Also label the two lakes. Capture your map.

What is the driving distance across South Dakota along Interstate 90, in miles? In
kilometers?

Set up labels for the towns in South Dakota such that cities with more than 25,000 people are
labeled in 14-pt. bold text, towns with more than 5000 people are labeled with 10 pt. boid
text, and hamlets with less than or equal to 5000 people are labeled with 8 pt. italic text. Set
the scale range on the hamlets so they do not show when zoomed out beyond 1:2 million.
Capture a map of the entire state showing the labels, and capture another one showing the
southeast corner of the state with the hamlet labels.

TIP: To select the towns, set up a double expression that looks like [POP100] > 5000 AND
[POP100] < 25000. The field name must be repeated for the expression to work correctly.

Io.

Add another data frame to the map that contains the lower 48
states with a light blue symbol, and rivers and lakes with a : e
dark blue symbol. Group the lakes and rivers as a single layer | South Dakota

named Hydrology. Place South Dakota on the map in dark B —
purple, and label it with a callout label.

Make a layout with the two frames. Put on the title South
Dakota and put your name below it. Print the map to turn in.

Create a labeled school map of Sioux Falls, just as you did for
Rapid City, using annotation to get the best label placement
possible. Label it with your name in one corner. Capture

your map.

Chalienge Problem

Create a United States map layout showing the conterminous states as well as Alaska and Hawaii.
Use three different data frames, and include at least three different feature classes of your choice,
using the same ones for all three frames. You don’t need to include a legend. (Hint: Right-click
a layer and notice that you can copy and paste layers between frames.)
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Starting ArcMap

ArcMap

ArcMap can be started several ways.

ArcCatalog

1. Click the Start button on the Start Menu bar of the computer
and navigate to Programs > ArcGIS > ArcMap, and click it
to start.

Fig. 2.28. Program icons

s 2. Find the ArcMap icon on the desktop
) and double-click it (Fig. 2.28).

3. Click the appropriate button in
ArcCatalog (Fig. 2.28).

4. As ArcMap starts, it displays a dialog
screen (Fig. 2.29). Choose to start with
a new empty map, open a map template,

or open an existing map. Browss lor maps...
C:\mb\MGIS ibkmgisdatatM apDocurnents temp2 mrd

C:AmbA\MEIS ibhngisdatatM apDacurentsiex_1.mxd

5. To open existing maps, click Browse for C\mbSM 1S bkibrantemptex_1finish med
. C:AmbM astenngG1S smgisdataMaph ccumentshes_1.mud
maps to search for a map on the disk, or CAmb\MEISibSngisdatash acDocumentster_4 mud

click one of the recently used maps
shown in the list.

Fig. 2.29. ArcMap start-up dialog 95
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Managing toolbars

1. To move a toolbar to another location on the GUT, click and hold on its handle (a shadowed
line on its left edge) and drag it to the desired position (Fig. 2.30).
This is a docked toolbar.
Handle

2. To move a toolbar off the GUI entirely, use the handle to drag it off
the GUI. Tt then becomes a floating toolbar. It can be docked again
by dragging it to a location on the GUI,

. . . Fig. 2.30. H
3. To open a toolbar that is not present, right-click on a toolbar or empty '8 andle

space and choose the desired toolbar from the alphabetical list.

4. To close a toolbar, click on the X box in its upper right corner, OR right-click on a toolbar or
empty space and choose the toolbar to close from the Hst,

Adding data

L. Click the Add Data button on the main toolbar OR choose File > Add Data from the main
menu bar,

2. Use the Add Data dialog box to navigate to the folder containing the data to open.

3. Click on the data layer to select it. Select multiple Iayers by holding down the Control or
Shift key while clicking additional data sets.

4. Click Add. The data will be added to the active data frame,

TiP: If the disk or directory containing the data does not appear in the list, you probably
need to add a connection to it using the Add Connection button, as described in Chapter 1.

Saving an ArcMap document
1. Click on the Save button, OR choose File > Save from the menu bar.

2. If the document has not previously been saved, a dialog box appears for the user to select a
location and name for the map document. Navigate to the directory to save it to, and then
enter a name for the document.

3. Choose File > Save As from the menu bar to save the map document under a new name,
leaving any previously saved version unchanged. Specify the location and name as for step 2.

TIP: The names of map documents, spatial data sets, and folders should not contain spaces or
unusual characters such as #, @, &, *, etc. Use the underscore character _ to create spaces in
names if needed. Although ArcCatalog and ArcMap allow spaces in names, the spaces can create
problems for certain advanced functions. Thus, it is wise to avoid them entirely.
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Opening an ArcMap document
1. Click the Open button OR Choose File > Open from the main menu bar,

2. Use the dialog box to navigate to the directory containing the file.
3. Click on the file to select it and choose Open.

4. If the currently open map has unsaved changes, you will be prompted to save them before
opening the new document. ArcMap can only open one map document at a time.

5. To create a new, empty map document, click the New Map File button, OR choose File >

New from the main menu bar.

Controlling display with the Table of Contents
1. To turn a layer on or off, click inside the check box.

TIP: Ifthe check box is dimmed, then the current map scale is outside the display range set for
the layer. Try zooming to another scale, or reset the scale range in the layer properties.

2. To change the draw order, click and hold on the layer name and drag it higher or lower in
the list. A black bar indicates where the layer will be placed. Release the mouse button to
finish.

TIP: If the layers don’t seem to go anywhere when you drag them, and the black line does not
appear, check to make sure that the Display tab in the lower right corner of the Contents box 18
clicked. You cannot move layers when the Source fab is clicked.

3. Hide the legend for a data layer by clicking the minus sign in the box next to the layer. Click
the plus sign to expand it again.

Setting Map Tips
I. Right-click the name of the layer in the Table of Contents and choose Properties from the
context menu.

2. Click the Fields tab and set the Primary display field for the text to appear in the tip.

3. Click the Display tab and check the box to Show Map Tips.

TIP: If the Show Map Tips box is dimmed, then you must create a spatial index for the layer
using ArcCatalog.
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Grouping layers for display
Grouped layers can be turned on and off with one mouse click.
. Click the first layer in the group to highlight it, and then click the other members of the group

while holding down the Ctrl-key. When you are done, all the group layers should be
highlighted in blue.

&
2. Right-click a member of the group and choose Group (Fig. 2.31). &
3. Click on the New Group Layer name once to highlight it; then click on it again to type in a
name for it. Press Enter to finish.
| B E B ¥ D watdr
= Rivers
1 ER * —
g = Lakes
= Counties BB
.
New Group
e

Fig. 2.31. Creating a group layer

Groups have joint properties such as setting scale ranges for the entire group at once. You can
also add group members directly from the disk without needing to add them to the map document &
first. All layers in a group must be in the same data frame.

4. Right-click on the Group name and choose Properties from the context menu.

5. Click the General tab to set scale ranges for the group.

6. Click the Group tab and click Add to add more members to the group from the disk. Use
Remove to remove members from the group. The Properties button is used to specify
different properties for individual group members.

7. Click the Display tab to set transparency, brightness, or contrast for the group.

98




Working with ArcMap

Using the Zoom/Pan tools and other zooming techniques

1.

10.

1.

12.

To zoom in to an area, click the Zoom In tool. Position the cursor to the upper left of the arca
to zoom to; then click and drag a box to encompass the area desired. Release the mouse
button to finish.

To zoom out, click the Zoom Out too} and click once at the center zoom point. Draw a large
box to zoom out slightly, or a small box to zoom out a great deal.

To zoom in by a fixed amount while remaining centered within the current extent, click the
Fixed Zoom In tool.

To zoom out by a fixed amount while remaining centered within the current extent, click the
Fixed Zoom Out tool.

To move the map, click the Pan tool, click on the map, and drag it to the desired area.
Click the Previous Extent button to return to the extent just before the current one.

Click the Next Extent button fo return to the extent after the current one (this button is
dimmed unless the Previous Extent button has been clicked).

Click the Full Extent button to view the full area of all the layers in the data frame.

To set a bookmark, zoom to the desired area and click View > Bookmarks > Create. Type in
a name for the bookmark.

To zoom to an existing bookmark, click View > Bookmarks and choose the desired
bookmark (Fig. 2.32).

To delete an existing bookmark, choose
View > Bookmarks > Manage. Select the
bookmark name by clicking on it, and
click the Delete button.

To zoom to the reference scale, right- _
click the frame name and choose Zoom — )
to Reference Scale from the menu. Fig. 2.32. Zooming to a bookmark
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Identifying features ©
1. Click on the Tdentify tool. ‘

2. Click on the feature to identify.

3. Clicking the identified feature in the dialog box will cause it to flash briefly (Fig. 2.33). e

Sometimes you may have difficulty geiting the right feature identified. Identify has some options %
to help: selecting the feature from the top layer, from the selectable layers, from all the layers, or '
from a requested layer.

4. In the Identify Results box, click the
drop-down list at the top and select the
option or layer desired.

5. If All Layers is the option selected, a list
of features appears in the Results box, all | SO
of which were present at the point 1 Path B1EIZO62EST
clicked. Click on a layer to view the SR
attribute for that feature. Click ona
different layer to see its attributes,

Fig. 2.33. Using Identify

Measuring features

. Click the Measure tool. By default it measures
distances.

2. Click on the map to start the line. Click along the
path to be measured. Double-click to end the line.
Both the total length and the Tength of the last
segment are shown (Fig. 2.34).

SR

Click the Measure Area button to measure a polygon
area. Click to create vertices for the polygon and Fig. 2.34. The Measure tool
double-click when finished.

Click the Measure Feature button, and click on a feature to get its length, or area and &
perimeter.

Use the Choose Units button to set the units for length and area.

Use the Snap to Features button to make the cursor coincide with a feature when it gets close
to it. This option is useful for precise measurements between or along features.

Use the Show Total button to keep a running count of all features measured.

Use the Clear/Reset Results button to clear running totals and reset the measurements.
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Finding features by searching attributes
1. Click the Find tool and type the text to search for in the first box (Fig. 2.35).

2. Choose the layer or set of layers to be searched.
3. Check the box for an exact match or for features that are only similar to or contain the string.
4. Choose to search all fields, a specific field, or the primary display field.

5. Click Find to begin the search. Records that match the search wilt be listed at the bottom of
the Find box.

6. Right-click one of the found records to display a context menu with options for flashing,
zooming to, identifying, bookmarking, or selecting the found feature (Fig. 2.36).

-\ri; Adi g5 Mehrort Locstion

Fig. 2.35. Finding features Fig. 2.36. The Find list

Seftting data frame and layer properties
1. Right-click the frame or layer name and choose Properties from the context menu.

2. Click the tab containing the properties to set.

3. Enter the appropriate information and settings.

Defining symbols for a layer

You can set symbols a number of ways in ArcMap. Here are a few of the most common ways—
all of these assume that all features in the layer are being drawn with the same symbol.

Changing the color of the current symbol

1. Right-click on the layer symbol in the Table of Contents, and choose a color from the palette
that appears.
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Changing properties of the current symbol

1. Click on the layer symbol in the Table of Contents to
open the Symbol Selector window (Fig. 2.37).

2. Choose a symbol from the scroll box.

3. Modify the symbol’s color, size, thickness, outline, or
other attributes by setting the options provided. Make
additional changes using the Properties button.

4. To load additional symbols in the scroll box, click the
More Symbols button and choose from the list of
categories. Fig. 2.37. Symbol Selector

5. Use the drop-down Category box to change which categories are currently visible in the box.

6. Click OK when finished modifying the symbol.

Labeling features interactively

1. Look for one of the labeling tools on the drawing toolbar. Click on the
black arrow for a drop-down menu to choose one of the tools.

. Adding text to the map
1. Click the Add Text tool.

2. Click the desired location on the map and enter the text, Press Enter when finished.

3. Newly entered text is always selected, as shown by the dashed blue box around it. At this
point you can change its font, size, or color using the menus on the Drawing toolbar. Or use
the cursor to click and drag it to a new location.

TIP: To delete text, click the black arrow on the Drawing toolbar, click the text to select it, and
press the Delete key. You can also use the black arrow to draw a box around many text boxes, or
hold down the Ctrl-key to select multiple text boxes for deletion,

TIP: To delete all graphic elements including text, choose Edit > Select All Elements from the
main menu bar, and press the Delete key. Be careful! This option also deletes any annotation
saved in the map document.
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Labeling a feature with its attribute

L.

If needed, right-click the layer name, choose Properties, and click the Fields tab. Set the
Primary Display Field to the desired attribute to appear in the label. Click OK.

Choose the Label tool from the labeling drop-down button. The Label Tool Options window
will appear.

Choose whether to find the best placement (e.g., the center of a feature) or to place the label
where you click. Also choose whether to use the symbol properties already set for the layer
or to choose a new symbol style now. Click the X box to close the window.

Click on the feature to be labeled. ArcMap will label the topmaost layer clicked, if more than
one layer is present,

TIP: The text symbol is set for the layer using the Layer Properties. Modify the default symbols
by right-clicking the layer name, choosing Properties, clicking the Labels tab, and setting the text
symbol,

Splining text from an attribute along a line

Splining text makes it follow along a linear feature such as a road or stream.

1.

Set the font size and style options desired using the Drawing toolbar.
Choose the Spline Text tool from the labeling drop-down button.

Click vertices to define the line along which the text will appear. Double-click to end the
line.

Type the text in the box and press Enter.

Use the Drawing toolbar to modify the position or font characteristics as needed.

Adding a callout label
A callout places text in a box with a pointer to the feature of interest.

1.

2.

Choose the Callout Text box tool from the labeling drop-down button.

Click on the feature to be labeled, hold, and drag to define the direction and length of the
callout pointer.

Enter the text into the box and press Enter.
Click and drag on the text box to change its location, if desired. Click and drag on the blue

dot to change the location of the pointer. Use the tools on the Drawing toolbar to modify the
callout’s font, style, size, etc.
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Creating wrapped text boxes %

1. Choose one of the wrapped text tools: the New Polygon text, the New Rectangle text, or the
New Circle text.

2, For the circle or rectangle text tool, ¢lick and drag to draw the circle/box, releasing the mouse e
when it reaches the desired size and shape. For the polygon tool, click on each vertex to &
define the desired shape, and double-click when finished.

3. Click in the empty shape to open the
text Properties box (Fig. 2.38). Type Properties:
in the text to be displayed. Do not = _

use the Enter key unless you wish to
enforce a new line within the text,

This map shows the iocation of public schoals in A apid City, 53
1Dakota, poluding the university 50 Tech.

4. Set the symbol, spacing, or other
options if needed.

5. Use the other tabs to change the
margins, columns, frame border,
size, position, or area background of
the text box as needed.

6. Click OK to place the text.

7. To modify the text later, double-click

0 open its properties box. Fig. 2.38. Wrapped text properties window

Setting the reference scale
1. Use the Pan/Zoom or Bookmark tools to zoom to the desired scale.

2. Right-click the data frame name in the Table of Contents and choose Reference Scale > Set
Reference Scale.

TIP: To set an exact scale value such as 1:24,000, right-click the data frame name, open the data
frame Properties, click the General tab, and type a specific reference scale in the appropriate box.

3. Toremove the reference scale, right-click the data frame name in the Table of Contents and
choose Reference Scale > Clear Reference Scale.

4. To zoom to the reference scale, right-click the data frame name and choose Reference Scale >
Zoom to Reference Scale,

TIP: Annotation, once created, retains its original reference scale set when it was created, even if
the reference scale of the data frame is changed later.
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Labeling features using dynamic labels
1. Right-click the layer name in the Table of Contents and choose Properties from the menu.

2. Click the Labels tab.

3. Check the Label Features box
(Fig. 2.39).

4. Make sure the method is set to
iabel all the features the same
way.

5. Choose the Label Field. Click
the Expression button to enter
a VBA (Visual Basic for
Applications) script.

6. Edit the font settings, or select
a predefined text symbol by
clicking the Symbol button
and choosing a predefined
symbol style.

Fig. 2.39. The Label Properties window settings

7. For detailed control of label placement, click the Placement Properties button.

8. Set the scale range if desired, by using the label’s scale range, or typing in new values. If the
map scale is outside the specified range, the labels will not be drawn.

9. Select a label style, if desired. A label style includes BOTH a text symbol and predefined
label placement options.

10. Click OK to place the labels.

TIP: Turn labels on and off for a layer by right-clicking the layer name in the Table of Contents
and choosing the Label Features option. If the menu choice is checked, the labels are on, and
choosing it will turn them off. If it is unchecked, choosing it will turn them on,
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Converting dynamic labels to map annotation

These directions show how to create annotation stored as fext graphics in a map. Consult the
Help files for information on creating annotation as a geodatabase feature class.

1. Use the Layer Properties to create dynamic labels for all the desired layers. Take care in
setting the properties, weights, and so on, because these will control the labels that appear.

2. Annotation will be created for all layers in the data frame with dynaruic labels turned on.
Turn off any dynamic labels for layers not to be converted.

3. Right-click the data
frame name and
choose Convert
Labels to Annotation.
The dialog box will
appear (Fig. 2.40).

4. Examine which layers
will be converted to
ensure they are the
desired ones.

5. Choose to create
annotation in the map.

6. Check the box to
Convert unplaced
labels if you want to Fig. 2.40. Creating and
place overlapping placing annotation
labels interactively.

Lincoln
7| Wast Junior High

mols Anro
Schoels Anno

7. Click Convert to create the annotation.

Unplaced labels will be placed in an overflow window if
you checked that option. The next step is to place these
labels interactively.

8. Right-click a label in the overflow list and choose a

method to locate it (flash, pan, zoom, etc.). e
9. Choose Add Annotation to add the label to the map. &
Click and drag it to adjust its focation if necessary.
10. If you decide not to place the label, delete it from the list using Delete,
1. Use Show Annotation In Extent o list only the fabels in the current view. Place all of these o
before zooming to another location—it saves time.
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Creating a map from a template

A map template is a set of data frames, titles, styles, and other map elements which are already
formatted and ready to receive the data in the data frame(s). Use a map template to quickly create
a map using a standard format. You can also save your own map as a template to create a similar
map again.

1. Click the Change Layout
button in the Layout
toolbar.

MiltarPortrail. st
2. Click one of the tabs to see Htifes. it
a choice of templates (Fig.
2.41). Templates you have
created will be stored in
the My Templates tab.

3. Click on a template to see
a preview of it

4, Use the Browse button to
navigate to another
directory containing more Fig. 2.41. Choosing a map template
templates saved elsewhere.

5. Click the Thumbnail button to see icons of all the templates; click the List button to go
back to the onginal list view.

6. Click the desired template and choose Next or Finish.

TIP: If the template has more than one data frame, it will prompt the user to assign the data
frames in the map document to the data frames in the template.

7. Ifthe data frames need assigning, click
each of the frames in the list on the left
(Fig. 2.42).

8. Use the Move Up and Move Down | RN el e e
buttons to put them in the same order as
the numbered frames in the new layout.

9. Click Finish.

10. Finally, change any titles or other map
elements in the template which need to
be customized.

Fig. 2.42. Assigning map frames to the
template
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Printing a map
1. To preview a map to
see how it will ook on
paper, chose File >
Print Preview from the
main menu bar.

2. To print, Choose File
> Print from the main
menu. The Print
window appears (Fig.
2.43).

3. To change the printer
or its properties, click
the Setup button.

4. Set the number of

copies to print. Fig. 2.43. The Print window

5. Choose the desired tiling options if the map is larger than the printer paper.

6. Preview the layout placement on the page. Click OK.

Exporting a map as a picture file

You can export a map as an image file to put it on a Web page or inside another document, or as a
PDF to share it with others.

1. Choose File > Export Map from the main
menu.

2. Navigate to the folder to save the picture
file (Fig. 2.44). Choose the type of file
and enter a name for it.

3. Click the gray arrow for more export
options, such as the resolution. If
planning to enlarge the map before
printing, increasing the default resolution
may be necessary.

4. To avoid having a white border around
the picture, check the box to Clip Qutput
to Graphics Extent.

Fig. 2.44, Exporting a map as a picture

5. Click Save.
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